Sketchup hangs up - erratic orbit operation - autosave hangs


#1

I am having a couple issues with SU. If I need a topic for each let me know.

  1. I asked SU Make 2017.1.174 x64 to EXPLODE a group last night. After a while I went to bed. This AM it was still using 12.5% of my CPU but no progress. I force closed the file. The group is one item expanded x10. It happens often but not all the time. I tried again this AM with just that item in the file and it does the same thing. When I force close the file it tells me SU is not responding. I tried it with the object at 1x and it took a while but completed - maybe less than 30 min - I went and had breakfast so I don’t know when it finished.

  2. Orbiting seems to be erratic at times. Occasionally, it will jump so far away from the model that I can’t find it and I have to roll around simply to find the origin then scroll a LONG way to get back to it. I am not sure if scrolling faster when the pointer is not on an object is a “feature” or an issue since it does not do that all the time. Sometimes it moves VERY slow if the pointer is not on an object. I don’t understand??? I have a mouse with a free wheeling function and use that most of the time with SU. That is good and bad, but why is SU unpredictable and what is this instantaneous jumping to the back 40 all about?

  3. Occasionally, when autosaving, it will hang forcing me to force close it. The autosave file that is created is good, but the temp file is still there. It appears like it has trouble closing the temp file. When it works the temp file is closed and it return control to me.


#2

This is when you use the Zoom Extents command.

Because you are zooming towards infinity. How long do you think that will take ? :wink:

Ie, always point at a model object when using the scroll wheel.


#3

Yeah I forgot what that was - HOWEVER, that is a workaround. Why does it
jump randomly to begin with?

Sometimes the pointer is not on an object. when I scroll it move v e r y
slow with the object in view. At other times it move as fast as it does
when the pointer is on an object. Sometimes one click of the mouse wheel
sends it to ∞, other times it doesn’t hardly move.

It never uses more than 12.5% of my CPU but takes forever to group and
ungroup things. Most of the time is does autosave just fine, other times
it hangs, seemingly trying to close the temp file because if I force
close it and reopen the autosave file it is fine. I have an i7 and 8GB
ram and a gts570. not the most powerful but these problems just keep
getting worse with 2017. The issues were not as bad with 2016.

Now I understand that all of this is me or my system. If that is the
best I can get. thanx.

[DanRathbun] DanRathbun http://forums.sketchup.com/users/danrathbun
Top Contributor
February 13

bill_ruggirello:

Occasionally, it will jump so far away from the model that I can't
find it and I have to roll around simply to find the origin then
scroll a LONG way to get back to it.

This is when you use the Zoom Extents command.

Yeah I forgot what that was - HOWEVER, that is a workaround. Why does it
jump randomly to begin with?