SketchUp GUI too small on Surface pro 3 even when global scaling to 180%

Hi, I’d like to see Sketchup to have robust scaleable GUI for the next generation of display resolutions. My Surface Pro 3 uses 2160x1440 and I have to use global scaling of 180% to make other programs usable and fill the screen. Sketchup Make 2015’s GUI however is extremely tiny at this setting and unusable by touch. I’ve worked around this by downloading a beta virtual tool bar that I can map the buttons too, but there are still many areas of the screen, like the dimensions input display in the lower right corner, that are all but unreadable, and you really shouldn’t have to use a 3rd party toolbar just to make the buttons accessible with the touchscreen. Because of the finickyness of scaling with high resolution displays with other programs, sketchup’s gui should be completely and fully scaleable itself rather than just making one 2160x1440 option, that would allow for some give if people are using different global scaling settings for other programs to work.

Welcome to the world of high-dpi (dots per inch, i.e. size not merely number of pixels) displays! There have been multiple previous posts on this general topic going back several years. Hopefully now that more than just Mac Retina has this issue there will be enough market to convince Trimble do something about it.

We hear of users modeling with a touch pad or touch screen; but it’s not how SU is designed to work.
You’ll be far more efficient using a three-button, scroll-wheel mouse.
A programmable five or seven button mouse or a 3D navigator mouse is better still.

Again someone who enjoys a next generation device (too)! Unfortunately, touch and high-dpi together are even harder if the application doesn’t support it (even with a mouse, vertices and points are hard to pick).

I’m not going to trade in a future-proof purchase decision for a sub-standard machine only because of SketchUp. I believe a lot of SketchUp’s users especially benefit from higher resolutions and tend to be on the left side of this graph. It’s not the kind of application where the owner can afford missing the trend.

See here for more options how to work with SketchUp under these conditions, for example different solutions to upsample the SketchUp window (application-specific scaling was disabled for SketchUp 2014, but it could possible work in SketchUp 2015).

Well I’m just starting to learn 3d modeling and Sketchup. The resolution issue is more of a bug then a feature request, which is why I originally posted this in technical support. Even when using a mouse, which I have used to make learning models, The GUI and text is way too small on the Surface 3, and changing the resolution on the surface isn’t an option, cause it moreless just subtracts pixels and adds black lines to the screen. I’m uploading two pictures, both screen captures.

The first shows how small everything is to navigate and read including the measurements tab…

The second is with an added touch toolbar program that maps to the buttons…
(Look for in second post)

You can find the toolbar from links on http://surfaceproaudio.com/surface-pro-3-pen-toolbar-daw-software/

I had originally hoped to do 3d modeling work with the surface pen in sketchup, and with this toolbar it actually works kindof okay. It would be annoying to use a mouse with it because it would keep re-positioning the cursor, but it jumps right back where you were with the pen. I’ve seen some videos of people paint sculpting with wacom pens in Zbrush pretty effectively and don’t see why Sketchup wouldn’t be able to do the same, or want to for that matter, with their own toolbar on the side for changing functions with the pen. Really the side buttons that are in the picture would be fine if they were just bigger, like about the size of the shown toolbar buttons. That and the text boxes, like measurement box etc, just need to be bigger. The one other major thing that would be easy enough to fix to make the pen work, is to make an option to display the floating text that displays along where the cursor is (endpoint example) , is to display the text to the left of the cursor instead of the right, possibly at some adjustable distance, for right handed users. Otherwise the pen covers up the text.

These would be really simple fixes I would think. I haven’t encountered anything in the main program that wouldn’t work in general. The Gui just needs to be bigger, and all of the text boxes need to be bigger, and the Cursor text could have a “float to the left” option for right handed pen users. If you added programmable buttons for users to map keyboard shortcuts that would be icing on the cake. If you really wanted to, you could combine touch with pen and make it so you could set a button to only function when your holding it down. Like for orbit, pan, and zoom and then have it jump back to a previous tool. Again in conjunction while using the pen to draw. The resolution or scaling needs to get upped either way or no one using a surface pro 3 will be able to effectively use sketchup even with a mouse.

1 Like

One other thing that would be helpful, is a number pad pop up or something with in/cm/etc buttons to dial in figures, which could have it’s own programmed button on the side to call it up when needed. That would need to override the windows 8 keyboard in tablet mode.

1 Like

I was considering buying a Surface Pro and I use SketchUp extensively. Thanks for the review!
Question, though: Can’t you still program the keyboard for custom shortcuts? Search for how to do that, I’m sure it’s an option. In Preferences, maybe?

One dumb question: Are the SketchUp toolbar buttons seen in your screenshot large or small? (Window menu>Preferences>Workspace)

Anssi

I have “use large tool buttons” checked in the workspace tab.

I also use the Surface Pro 3. I have purchased the Surface pro 3 dock and run an external 27" Monitor with a 3d connexion mouse and all works great. The surface Pro screen is way to small for Sketch-up in my opinion.

And this confirms that the problem is with dpi, not number of pixels per se. The 27" is large enough that the same pixel counts are spread out at a smaller dpi.

Just got a surface book so I can work on the go. Thank God for '16 and the dedicated graphics card

Anyway, I got really annoyed having tiny DC text on both here and my home setup, found this forum, then accidentally stumbled across something. With the cursor in the DC window, I did the finger spread input on the track pad and wouldn’t ya know it the contents changed size! im guessing this is just like ctrl+ for a browser window? Someone confirm or I will when I get home. Out of time for the evening

The component options window is, in fact, an IE browser window. Dynamic Components is a plugin integrated into SketchUp, and plugins use webdialogs for their popup windows.

Anssi

Wow, interesting. Well that solved my usability issues on a high-dpi screen. Now I can program from anywhere. Doing hurricane relief in Florida by day and DC programming by night :slight_smile:

For the rest, I can only suggest a keyboard and thoughtfully mapping all your shortcuts. Or maybe get a stylus? I wouldn’t call the icons untouchably small (again, I’m on a Surface Book). At least you can retap if you accidentally pick the wrong one