Screen resolution


#1

I’m having an issues with Sketchup resolution (I think). In the tools bars window, the text is smashed together. Also, my tool buttons and select tool are very very small. See picture below. Thanks in advance for all help.


#2

(This belongs in the “Technical Problems” sub-forum.)

When posting problems & issues, you need to supply technical specifications;

SketchUp edition name: Make / Pro
SketchUp full version major.minor.build numbers

OS edition name: Home Premium / Pro / Ultimate / Mavericks / Yosemite / etc.
OS full version major.minor.build numbers
OS Service Pack Level (MS Windows)

If a Graphics Issue:
Graphics Card/GPU make & model
Graphics Driver version major.minor.build numbers

If Display Issue:
[If multi-monitor, specify the mode: clone / extended desktop, etc.]
[Specify which is the primary display in extended desktop mode.]
Display monitor make & model
Display Resolution setting
DPI if not the norm like 96dpi.
(repeat for each display monitor)

If a WebDialog issue:
MSIE or Safari full version major.minor.build numbers


#3

name: Make
OS: Windows 8.1
Graphics card: Navidia GeForce GTX 870M
CPU: Intel® Core ™ i7-4702HQ CPU @ 2.2 GHz
Current Resolution 3200 x 1800, 60 Hz


#4

http://www.videocardbenchmark.net/gpu.php?gpu=GeForce+GTX+870M&id=2833


#5

I don’t understand. The font is a tolerable size and I have “large icons” checked in preferences. Why are the buttons and select tool so small?


#6

The buttons are small because you’re resolution is 3200x1800. What size is your monitor? The best I can recommend is to experiment with the toolbar positions.

SketchUp’s “large” tool buttons aren’t really much bigger than the “small” ones. This is just a UI issue that needs to be updated; especially with more and more high DPI monitors on the market; programs will need to scale up.


#7

What you are seeing is an application that is not completely resolution independent. This is a UI issue and neither related to graphics card, nor is there a toolbar option.

There is no real solution, sorry for that. Let’s hope for SketchUp 2016 to fix this (if no wonder happens before that).
This topic has been discussed here with some work-arounds.


#8

Thanks, Dan and Aerilius.

Dan, I’m on a razor laptop.

Aerilius, I came across that thread just recently and was a bit discouraged seeing there wasn’t any resolution. I’ll keep my eyes open for any updates related.

Thanks again.


#9

Really? 262 ppi, that is crazy sharp, but SketchUp is behind in supporting this.

Post a request in Feature Request forum.


#10

I also have this issue on a 15.6" 3840x2160 laptop with Windows 8.1. It would be great if there would be a way to make the icons and status bar super-extra-large, and there are other visual bugs induced by the windows being in high-dpi-mode.

The one issue I have which I hope isn’t overlooked is the sensitivity of the mouse pointer isn’t aware of the high dpi, so on my 24" 1920x1200 monitor the proximity at which a pointer/tool will snap to points and lines is about right. I’m guessing at these number, but if the “snap” distance is ~5px on that low-dpi 24" monitor it should be ~15px on the high-dpi 15" monitor. As it is I have to lean in and be very careful as I try to click on my target.


#11

The only workaround for the snap distance is to upsample the Sketchup window. Try if it is now possible for SU2015 to enable Display scaling on high DPI settings, otherwise you could reduce the global screen resolution or run SketchUp in a virtual machine that supports scaled mode. Works sufficiently well, but embarrassing having to recommend that.

It’s not that there hasn’t been enough time and testing opportunities before this issue became main stream. What’s the purpose of issue reporting and testing, if there is nothing to test?

It reminds me of a couple of infamous construction projects that have been busy on completion for years.
The mayor: “The plan is that it will happen in January two thousand… two thousand and si… which? two thousand seventeen…”