4k Display Issue in Sketchup or Toolbar Bug?


#1

Hi All


I have a brand new HP Spectre 360 Laptop with a 4k display. Everything seems to work fine except when I open the toolbar window it’s not quite right. There is no slider to scroll through the different toolbar options and the checkboxes to the left of each option are funky. I’ve attached a screenshot here. I thought it might be a 4k display issue but every other menu and feature seems fine. Have you seen this error before? I have also recently installed Sketchup on a brand new iMac 27" and have no such issues with that display. Thanks.


#2

Well this morning I rebooted the computer again and it seems to have fixed itself.
I tried rebooting a couple of times yesterday and it didn’t help but today it did.
If anybody sees a bug like this let me know.

Thanks!


#3

Well I fired Sketchup up again today and the bug is back. Same issue as before. I also noticed that the materials pull down menu is compressed. See screenshot. Has anybody seen behavior like this?


#4

I haven’t tried SketchUp on a 4K display, but I understand that only the 100%, 125% and 150% display scaling options work somewhat reliably.

Anssi


#5

SketchUp Hardware and Software Requirements says:

High DPI Support
SketchUp is DPI aware and can adjust the sizes of Icons and drawing elements so they are sized correctly for High DPI screens. Icons are sized when SketchUp starts up. If you adjust your DPI or scaling (Microsoft Windows – but only up to 150%) you will need to restart SketchUp to see correctly sized Icons and drawing elements.


#6

Thanks for the info Dan. That does seem to be true. I changed the scaling in the display settings to 150% and that did the trick. The problem with that is the icons and menus become too small IMO for a 15" laptop. The solution I found was to change the resolution in the display settings to 1920x1080 and that solved the problem. I would say 1920x1080 looks good on a 15" laptop. However I will mostly use my laptop hooked up to a dock with a 27" 4k display attached. When I do this I’ll leave the resolution set to my laptop’s native 4k resolution (3840x2160) and change the scaling to 150% and the smaller icons look fine on the larger 27" monitor. This method seems to work for me so far. I’d be interested in hearing other people’s experience with this issue as 4k is becoming more common. BTW I returned the HP Spectre X360 and bought the Dell XPS 15 for the extra quad core processing power. Thanks!