Sketchup fuzzy when zoomed in


#1

Hi there,
I am working on a file that is 14 MB. I recently imported an iMac computer model into my file. I noticed it getting bogged down (slow) after I imported that. I then deleted it and went to Window>Model Info>Statistic>Purge unused but am still having issues with how my model looks and behaves. I have attached a screenshot. Basically, when I zoom in to edit a group or something, the edges get really fuzzy and it can be difficult to work with. If I need to push/pull an edge of plywood in my model, Sketchup has difficulty recognizing the thin edge I am trying to work with and keeps snapping to the broad faces of the plywood. Any help or trouble shooting ideas would be great! Thanks.


#2

You mentioned purge, which is a good way to reduce file size, but doesn’t generally improve performance because it just eliminates stuff that isn’t being used anyway. In the Model Info->Statistics, what does SketchUp say about the number of edges and faces in your model? Have you imported any components from the 3D Warehouse into your model? There are a lot of models in the warehouse that are vastly over-detailed to be used as “entourage” in a model.

While editing the model I would choose monochrome style. Requiring SketchUp to render textures will definitely slow it down, and doesn’t show you anything you really need to know while editing. Also, as you zoom in tight, texture images may reveal flaws such as blurriness, that aren’t evident at normal size.

It is a fact of life that sometimes SketchUp’s inference engine will aggressively snap to something other than what you wanted. You can usually work around this by zooming and orbiting so that your desired target is better separated from other potential snaps. But the struggles are why ability to turn off selected snaps is a frequently requested feature.

In your image I can see some zig-zag “aliasing” along edges. Is that what you mean by “blurry”?


#3

Your use of terminology is confusing.
By edge of plywood you probably mean the side of the highlighted group in your screenshot.
Otherwise: Push/Pull doesn’t work on edges, only on faces.

See (via the ‘Outliner’ if there aren’t any instances of the downloaded model left in your model that prevent purging them entirely.
Also, are imported materials applied to edges, also preventing them from being purged?


#4

Are you using high DPI screen? I’m thinking these jags are so small they might only be visible when high DPI scaling is used. Just a thought.


#5

Hi slbaumgartner,

Thanks for the reply. I have 75,000 faces and 165,000 edges. Does that sound like too many?
Yes, I have imported about 10 items from the 3D Warehouse, however, it was the iMac computer model that seemed to be the start of my issues, however that item has been deleted but the problem persists. I tried using the monochrome style lie you recommend, but it doesn’t help. And when I said I am “zoomed in”, it is not an extraordinary amount of zoom. I have done that before in the past and had a similar issue, but I was zoomed in super far. This is happening at standard levels of zooming required to move about the model and edit my drawing (which is a house comprised of 2x4 framing.)

Yes, the zig zag aliasing on the edges is what I mean by ‘blurry’.


#6

That is not a small model, but isn’t up to the level that I would expect to start causing serious performance issues.

Go to SketchUp->Preferences->OpenGL and try changing the “Multisample anti-aliasing” value.


#7

Hi Wo3Dan,

Thanks for the reply. I was using the word “edge” as you might use it in a non-Sketchup context. On that highlighted piece of 1/2" plywood I meant the 1/2" edge. I checked the Outliner. There doesn’t seem to be any instances of the iMac computer model left.


#9

I don’t see a “Multisample anti-aliasing value” in that file path…


#10

That’s not a file path, it’s in the SketchUp menu. I’m assuming you’re using SketchUp Make and not Free(the web version) which it says in your profile.


#11

Oops! My mistake. That setting was added in SketchUp 2018 and your profile says you are using 2017 (as noted, you most likely mean Make, not SketchUp Free which is the browser-based version). But if you are using SketchUp Free, slower performance on a model that size is not especially surprising. It’s a work in progress and still affected by browsers’ implementations of WebGL.

If you mean Make, did you update to the latest 17.3.116 version of Make? It contains some tweaks specifically for High Sierra.


#12

Hmmmm. Yes I am using the 17.3.116 version of Make. Thanks so much for thinking this through and helping me out. Maybe the problem will just go away just as it randomly appeared. haha!


#13

As usual, if you are willing to share your model here people can take a look and see whether they also encounter issues and whether they can find the cause.


#14

If I remember right, the 2017 version had issues with antialiasing on the Mac.


#15

The issues were that the antialiasing was completely removed from the Mac version. 2016 still had it I think. You had to use Ruby to turn on the feature.


#16

Thanks! (woops, I thought I had posted this weeks ago, but apparently it never went through! Take a look if you are curious to see the issue. I think people here have identified it as an “antialiasing” issue. (Which I have no idea what that means…) HUGE thanks to anyone who takes the time to look at this file.


#17

I figured out a solution! I just turned every layer on in my drawing. Highlighted everything and copied into a new clean file. Problem solved. That was easy.


#18

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.