SketchUp freezes as soon as I try to select an object

I just got a new laptop, and installed SketchUp Pro 2022 on it. Everything opens fine, and I can even draw some lines and shapes and stuff, but as soon as I use the select tool to try to select something, SketchUp stops responding. If there’s an animation in the help bar, it keeps loading, but I can’t click on anything or change tools or orbit my model.

I’ve updated my video drivers to the latest from Intel and reinstalled SketchUp. This happens even with all extensions disabled.

The computer is a Samsung Galaxy, with Intel iRISxe Max graphics. It should be able to run SketchUp fine, but I can’t seem to get past this problem.

First thing I would try is making sure the installation of SketchUp is correct. Close SketchUp, find the downloaded installer, right click on it, choose Run as administrator, and when given the option, choose Repair.

Strong idea, but didn’t help. Thank you!

Hmmm… So if you start a new file draw a rectangle and select it, SketchUp freezes?

Exactly this. Or, if I open an existing model and click on something, it freezes.

You have integrated graphics. Check from the Intel website that your driver is up to date and update the driver if a new one is available. In SketchUp, if Fast Feedback is turned on in the Window menu>Preferences>OpenGL dialog, try turning it off and restarting SketchUp.
Have you installed extensions?

In addition to Anssi’s post:
Did it ever work with Win 11? What version of Win 11 do you have? There are issues with the latest version. It may be related to the version you have.

I understand that the version in question is a Developer Preview.

SketchUp works fine on my other Windows 11 machine. I’ve updated my driver’s to the latest from Intel. I have all extensions disabled.

Nothing seems to be helping.

Which build of Windows 11 are you using on the machine that is causing you problems?

Windows 11 Home, version 21H2, OS build 22000.978. It is up to date with Windows Update.

Mike, I don’t know if this will give us better information, but it is something to try.

CheckUp gave me a clean bill of health when I ran it yesterday.

I’m going to try running SketchUp as an administrator as soon as Trimble’s authentication server isn’t broken.

When SketchUp is installed, the correct process is to right-click on the installer and choose “run as administrator”. This eliminates the need to run the software as an administrator. At this point right click on the installation file choose run as administrator and choose repair from the options. This should get things sorted.

I uninstalled SketchUp and reinstalled it as administrator. I also repaired it as administrator. Neither helped.

I did tick the box for “Use fast feedback” in the OpenGL settings. It’s working…for now. It’s fooled me before, though.

The Samsung Galaxy is sort of a PC version of a mobile device, it may not be able to run Sketchup. It’s a bit like a Chromebook, from what I gather, it may really be a fancy Android. I could be very wrong, but its a thought.