Sketchup Free Printing Issue: Scene Changing From Perspective To Parallel Projection

For the past couple of days, I’ve noticed that whenever I print a model the scene changes from perspective to parallel projection. When I return to the model after cancelling print the actual model has also changed to parallel projection. This has never occurred in the past. Has anybody else encountered this? If so, did you fix the issue and how?

1 Like

Have you updated the scene after changing to perspective?

Yes…I even saved after changing it back. Then I tried to print again with the same unwanted results.
Thanks for the quick reply, though.

I see that in SketchUp Go as well.

If one cancels the print and goes back to the model the camera is still in Parallel Projection.

It’s still very early in Colorado but when one of the team members gets in to work maybe they can take a look.

I had some trouble replicating the error you were getting, but then I realized you were using the print option instead of “export as PNG” because the error isn’t there.
I did notice that if you set the print mode to Print To Scale, it corrects the perspective (and retains it when you cancel out of the print). So, this error only seems to affect the Current View mode.

@DaveR …I feel your pain. Nice picnic table btw. Is that one of types where the benches fold up?

@wataru.kannuzuki…unfortunately, Print to Scale is only available with an upgrade. I’m too “frugal” to upgrade. I can always download as png if necessary. Thanks for the idea.

I am seeing some unexpected behavior.

@marwanobeidat look at SKIT-2499 from 4 1/2 years ago. That may relate to what is happening now.

We have some printing bugs that we are trying to address this year. I will add this to the scope.

Thank you.

1 Like

I found a workaround for when this happens, (apologies if someone has already said this one). First create a hotkey for switching on perspective view, I have mine set to Alt+P, (you can do this by clicking on the little dog chasing the red ball and typing in “perspective” then click in the little box to the right of the perspective option and type in your desired hotkey/hotkey-combo). Once you have a hot key for perspective you can print your drawing, when you are on the print preview page if you see that your drawing has gone back to the Parallel Projection view, simply press your hotkey/s and it should change it back right there from the print preview, now just press print. Hope this works for you too!