Sketchup for Web recently became slow & laggy

Good afternoon! I’ve been using SketchUp for Web since it became available, and has been running smoothly. For some reason over the past few weeks, when using the orbiting feature, the model becomes very laggy to navigate and zoom. No settings were changed on my PC that I am aware of. The selection tool also creates an infinite array of boxes when dragging to select a component (reminds me of the old school solitare screen after winning a game lol.) I know the settings are limited within the web based version, so I didn’t know if anyone could suggest any tips or troubleshooting.

This is generally related to graphics drivers. Go to the Nvidia site and make sure you have their latest graphics drivers. Also make sure your browser is up to date. Which browser are you using?

Also make sure you’ve got a clean model. That means purging unused components and materials.

Share your .skp file so we can see what you are working with.

1 Like

Hey Dave thanks for the reply. I went ahead and updated my graphics driver as well as my browser (google chrome). The weird thing is that it isn’t tied to a specific model that I’m working on. Even the files that were once running smooth in the past, all have this issue now. Now that I think of it, I went into the Nvidia control panel about a week or two ago and adjusted a few settings (I use my PC for gaming as well), and I’m thinking that possibly could be the culprit? I just don’t recall which settings were adjusted.

Below is what I get in every file I open when I click and drag the selection tool.

Maybe you need to reset the graphics settings. Check to see the state of Hardware Acceleration in Chrome. Change it and see what happens.

1 Like

That worked! I did switch it off, as it was one of the many recommendations for more FPS while gaming, not thinking that it would impact Sketch Up. I never would of thought to change that back if it weren’t for your help. I really appreciate it!!


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.