SketchUP for Schools staff and student user access without Google Classroom turned on in G Suite

All students and staff have access to Google Workspace for Education, all of our student and staff users are in there for our domain, What we have turned off for the majority of our staff and students is the Google Service, Google Classroom, and it looks like that is the issue. In my testing when I turned on Google Classroom for a staff or student user in Google Workspace the user could authenticate with their School Google Account and access SketchUp without issue that way and when Google Classroom is turned off, they cannot. However, turning on Google Classroom is not an option for us since our District uses Canvas and we do not want to give teachers access to Google Classroom. My question is really regarding why we have to specifically have Google Classroom turned on for our student and staff users to access SketchUP when all of our student and staff users are in our Google Workspace for Education domain. Is there a way for SketchUp to authenticate that a user account is in our domain that does not involve Google Classroom? Other applications are able to do this, so I am wondering why SketchUP needs to specifically have Google Classroom turned on when other applications that require a Google Account sign in do not. I have seen in the forum and through talking with support that education domains need to be Whitelisted/Safelisted, this step has already been done or at least I was told by SketchUP support that it was done. That does not fix the issue for us and turning on Google Classroom is not an option so we need a way for our users to be connected to our domain: without Google Classroom. Thank you for your time and help with this.

Thanks for the post @samitchell. You should not need Google Classroom to be toggled on to use SketchUp for Schools as far as I am aware. I even asked an expert to be 100% sure before I posted this so if you are still experiencing errors I am not sure what the problem is, but I can confirm that Google Classroom is not the issue.

I have also confirmed that you are in our approved domain database so that is not the issue either If I had to guess what the issue might be, I would guess improper deployment but without a better look at what you are seeing, I am just taking a shot in the dark here.

Now with all of that said, are you willing to run through the deployment process and make sure that is not the issue? I have linked the deployment process video in this post for reference, so just follow along with that and you should be up and running again.

If this didn’t work, let me know and we can go forward with troubleshooting a few more things.

Hey Casey,

I will gladly make sure our settings are correct; however, in my testing when I turn on Google Classroom for a staff or student user everything works and when I turn off Google Classroom, it stops working. The only variable I have been able to see that is causing the error is whether Google Classroom is on or off.

Hey Casey,

I sent you the screenshots to show you that all of our settings in the Admin Console are configured correctly for SketchUP and yet when any staff or student user that does not have Google Classroom turned on tries to login into SketchUP for Schools this is the error they receive:

The Screenshot with the error message was when I tried to login with my Staff User account when Google Classroom was turned off for me. I then turned Google Classroom on for my user account and now it lets me login:

I don’t see how Google Classroom is not the issue here

Hi @samitchell I’m sorry this has been so difficult for you. I took a look at our manual registration process and made an update to your school domain name. Could you please try logging in again with one of the accounts on the domain and let us know if you see any changes?

Hey Tori,

Thanks for trying that, I don’t think it fixed it though, here is a short video clip of what I see when logging into SketchUp for Schools with Google Classroom turned off:

Here is what happens when I turn on Google Classroom for myself and try to login again:

For some reason SketchUp still seems to want Google Classroom turned on, thanks again for helping us to try and fix this:)

Thank you for sharing those, and again I appreciate your patience! Our team is working to test a few things on our end to see if we can determine why this might be interfering with your access. We should hopefully have an update for you soon.

We are having a similar problem, we have sketchup allowed, but get the exact same error message for all users after signing in. We do use google classroom and sketchup has permissions for it. First reported to us today by a teacher.

For us the issue is entirely based on Google Classroom being on or not, hopefully they can get a fix on this soon, thanks for letting me know we are not the only District having issues!

From the video, do you know if your admin installed the app on the domain? Step 2 in the dialog.

I’m the Google Admin for my District and SketchUP is enabled and setup correctly. The issue is Google Classroom, we have it turned off because it competes with Canvas which is what our District supports. W/hen I turn Google Classroom on, logging into SketchUP works, when I turn it off, it does not. Hopefully they find a solution since turning Google Classroom on is not an option for us. Thanks for the reply!

Nevermind, I just tested it and it looks like you are right, I will have to confirm with some schools but it looks like they fixed it, thanks again!

Great, so you just had to install SketchUp Up for schools on your domain?

No, it was already installed, they must have fixed the needing Google Classroom issue, nothing changed on my end, SketchUP must have fixed the issue