SketchUp for Schools not loading

Hi there,
I previously used SketchUp for schools with my students 2 years ago and we accessed the app through the G Suite login and Google Classroom. I am wanting to use the app again for a project in a couple of weeks and I am no longer able to log in. The app is still installed and all permissions have been set correctly. Please can you offer any advice/support?

Kind regards.


Hi @kbrook, thanks for the post. I have not seen that one before. I’ll send a message to the rest of the team and see if they have any ideas, but the first step we always try is clearing the cache and cookies to make sure that there are no bad files in there that might be causing the issue. If you have a chance to try that while I am talking to the rest of the team, that might get you up and running sooner.

Regardless, keep an eye on this thread. I am sure that the rest of the team will have a few additional ideas for you to try soon.

Oh, can you please send us the error details when you have a minute? We may be able to gather some additional information from that.

HI, thanks for the reply. I have tried clearing the cache and it is still not working.
The error details are as follows:

Error 400: admin_policy_enforced

Request details: openid.realm= response_type=permission id_token redirect_uri=storagerelay://https/ ss_domain= prompt=select_account include_granted_scopes=true fetch_basic_profile=true gsiwebsdk=2 access_type=online scope= openid


Did you contact the school’s system admin about this. From what I can find on Error 400, this would be coming from your end. Or maybe more correctly, in between the Internet and you or your students.

Hi Casey, we are having the same issue and are getting stuck in a google sign-in loop, so none of our administrators can log in.
Can you please whitelist domain and website and offer any additional support to solve this issue?
Thank you!

Could it be domain issue for me too, I wonder? Can you please whitelist domain and website to see if that resolves our issue. Thanks.

Thanks for the posts everyone. First up I am happy to add you to the database @kbrook and @Ortiz, but if you are getting that 400 error, it looks like it is an issue with the permissions on your end and as a result, there is nothing I can do about it.

If you are the admin or super admin in charge of the domain, you will need to make sure the deployment process was done correctly as an improper deployment is one of the biggest causes of issues that we see.

Hello CaseyG,

We are good here enjoying the modeling web app. Appreciate adding our domain to the whitelist.

Hello @CaseyG at our school we have 2 domains, actually it is more like a one domain and one subdomain. I requested whitelist for and it works great. Can I have our subdomain be added to the whitelist as well. Thank you