Edu.sketchup page will not load

Sketchup https://edu.sketchup, loads icon after authenticating with google but never resolves. Chrome is up to date, and cache and cookies are cleared. Only happening with about 5 students. Anyone else having issues?

Hi @jpainter, thanks for the post and sorry to hear that some students are having difficulty accessing SketchUp for Schools. I looked into our database and servers and everything on our end seems to be working so my first guess is that there is a bad cookie or bad file in the cache. We can verify this by trying to see if they can load the app in an incognito window or clearing the cookies and cache. Can you try one of those and let me know what you see?

Thanks for responding. Yes, I have done these steps same result. Tried multiple browsers, cleared cached, and reset the browser. I tried using a home network VS a school network. Different computers etc. The issue follows the user. I checked the profile of the users having issues in the google admin console and noticed no issues. Do you want to set up a remote troubleshooting session so you can see the issue? Let me know, please.