Sketchup for Schools - Microsoft Store App

Hello! I am the Global admin for our School District and we have users trying to use the Sketchup for Schools Windows 10 App. When they attempt to login, it gives them a notice that their admin needs to approve it to be used.

I am happy to approve this on behalf of our users, but when I attempt to login to the app with my work or school account, it just cycles back to choosing which email I am going to use. I have MFA turned on for my account.

Our domain is

Are you able to sign into the app under your administrator’s account? I’ve included below a different set of instructions for you to try that may help. You should be able to give permissions directly through the app, so please let us know if this does or doesn’t work for you.

Make sure you are completely logged out of Microsoft. This isn’t normally necessary but will reduce the numbers of errors that could occur when logging in for the first time. You can use Chrome’s Incognito Mode, Firefox’s Private Browsing, or Edge’s InPrivate mode to guarantee that you aren’t logged in anywhere.

Access the application via SketchUp 3 and select the “Sign in with Microsoft” option when prompted.

A pop up window should appear. Make sure it isn’t hidden behind the main browser window! If a pop up window does not appear make sure your browser allows pop ups for the domain and reload the webpage.

Next, complete Microsoft’s login workflow using an administrative account for your domain.

Once you select the “Consent on behalf of your organization” and click “Accept” students should be able to login to the application also! If you see a different window it may mean that you are not using an account that has application consent permissions for your organization.

I’m having the same problem.
I’ve assigned the app to my users on the Windows Store for Education, I’ve logged in as a Global Administrator and approved the app. My users are all being told an Admin needs to activate it, despite all getting an invite by email to join the app.

I’ve seen elsewhere on here you may need to whitelist our domain names.
Can you add: and

I’ve have added your domain to our whitelist so you should now be able to login tp SketchUp for Schools.

Please make sure that you have also followed the steps above and have selected the “Consent on behalf of your organization” in the admin portal to approve the app for your school.

I’m still getting the an Admin needs to approve. I’m the global administrator and don’t get any prompts when I login, but my staff/students do. Any ideas what’s going wrong?