Sketchup files not listed in Windows Explorer folder


#1

I’ve saved some components in a folder in Windows Explorer using Sketchup 2017 on Windows 10. When I click on the ‘Details’ arrow icon in the Components tab of the Default Tray, and then “open or create a local collection”, it opens the correct folder in Windows Explorer, but the files aren’t visible.

I found a workaround: I used File>Import which opens the folder, but at first also didn’t show the files. The file type box had 3DS Files there as a default. I clicked the drop down arrow and chose Sketchup Files, and the files appeared. They are still not showing up through the component browser even though it opens the exact same file path.

The workaround solves the problem of not being able to get my components into a model, but I posted anyway in case someone has the same issue, and I am still curious why they’re not visible through the browser.


#2

When you installed SketchUp, did you install it by right-clicking and ‘run as administrator’. Strange things happen if you did not. Being the administrator is not sufficient. You can go to the folder where you downloaded the installation file, right-click on it and choose ‘run as administrator’. When prompted, choose the ‘repair’ option. You don’t have to unistall first.


#3

Thanks for the reply Mike, I don’t remember if I did that when I installed it, probably not. By the installation file, do you mean the .exe file that installed Sketchup? Because I can’t find that…I right clicked on the Sketchup icon that opens the program and chose Run As Administrator, but that didn’t make a difference on the files showing up in the Component browser. They do show up when I go through the Import command under File.


#4

He means the installer file, it will usually be in your “downloads” folder. If you deleted it, you could download it again.
Right click the installer, then choose run as administrator, then when prompted you can choose “repair” option. You don’t need to uninstall your current version of SketchUp.


#5

I guess I had deleted the file Thorleyian. Anyway, I downloaded it again and right-clicked and chose Run As Administrator, and then clicked on Repair when prompted as you and Mike have suggested. The problem with the component browser still persists though. I can reach the files through Import, but not the component browser. It really is curious since they both open the same exact folder path: This Computer>Documents>Sketchup>Components. With one I see all the files there, with the other- nothing.


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.