SketchUp 2017 doesnt recognized my saved components from SU2015 and earlier

collections
components

#1

I have saved to hard drive and flash drive a great many components from SU2015 and earlier that I often use. When I try to open these from within SU2017, they do not even appear in the folder as though they were not there. However when I click on them within the folder, 2017 opens a in new window with the component displayed. But I cannot bring these components into files I am currently working on. What is going on? What do I have to do to get these component libraries to read?


#2

This may be an issue with rendering the preview images for files contained on a flash drive. Have you tried copying a test folder to your hard drive and opening them from there?


#3

https://help.sketchup.com/en/article/3000118#organize-collections


#4

I AM trying to open them from my local hard drive through the SU2017 component browser in the default tray but no components show up in my personal component libraries on the hard drive.

However, If I go through windows explorer to open the personal components libraries on the hard drive, all the components appear and when I click on them they open in a new SU 2017 window. So in order to get the components I need, I have to go through WE, open the component in a new window and copy/paste to the SU file I am working in.

The problem is with the SU2017 default tray components browser. What is going wrong there?


#5

This is a system behavior known as “filetype association”. Ie, .skp file extension is associated with the SketchUp application. This usually happens with a double-click.

However, SketchUp on MS Windows supports drag and drop. Grab a model file and drag it into your current SketchUp instance and drop it in the model viewport. The MoveTool will be activated and you can move it’s instance wherever you wish. (By the way, you can also drag and drop many image file types into SketchUp, as well.)

okay, have you created subdirectories for you libraries in the user
"%AppData%/SketchUp/SketchUp 2017/SketchUp/Components" directory ?

Know that SketchUp must be restarted in order to enumerate these sub-directories if you’ve added them when SketchUp is open.

You may need to use the “Create a local collection” menu option from the component browser. (Help link top user guide above.)


#6

Did you click on Open or create a local collection… to open an existing directory of components?


#7

Yes, that is what I did.


#8

Ok. You never indicated that you did.

Out of curiosity, when you installed SketchUp, did you right click on the installer file and choose Run as administrator to install it correctly? If you didn’t, you should do that now and use the Repair option when prompted.


#9

No, my component folders are all located in another location on the C: drive under Documents.

Will the SU2017 component browser not read components in any other locations than folders in %AppData%/SketchUp/SketchUp 2017/SketchUp/Components folder?

If that’s true I have to move my component folders there.

Did this change from SU2015, which was my previous edition? I never had this problem with that edition.

Thanks


#10

Sorry, I omitted that detail. I do believe I installed it correctly, but I am not sure because, an issue did come up some time later that necessitated a reinstall with repair.

Thanks


#11

Yes, I have a “Components Master” folder there as well.

This is the default that it will always look in. And the only location that will be automatically enumerated.

Yes, prior versions (before 2017) had the basic “Components” folder in the program’s binary folder (which caused a lot of permissions issues.)

Not exactly.
But you must manually add any custom folder location path by “Open a local collection” followed by “Add to Favorites”.


BTW, You can change where the file dialogs look automatically, (on WIndows) via the settings in:
Window > Preferences > Files > Components

This should have worked to allow us to point the default user’s components folder somewhere else, but it doesn’t yet work as we’d like it to. This path feature only works when saving out a component from the current model.


#12

When you reinstalled with repair, did you r-click on the installer and choose Run as administrator?


#13

I put a few of my component folders from documents into
%AppData%/SketchUp/SketchUp
2017/SketchUp/Components and restarted SU but while that folder opens and
displays the subfolders, there are no component icons inside the subfolders
and nothing shows up in the browser.

Time to uninstall/reinstall again?.


#14

Perhaps. Make sure you right click on the installer and use Run as administrator.


#15

What version are the files? (I seem to remember, a cycle where the embedded icons were not written, or written incorrectly into the SKP files.)

If you switch the browser to Details (name only) view, are any files listed ?


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.