Components folder

The components window is not showing all components inside the local folder. I have tried restarting SU but to no avail. I think this started after upgrading to Catalina but not sure. Wondering if any one else has encountered this?

What happens if you navigate to the folder where components are stored (see SketchUp > Preferences > Files)? Do you see folders for the missing components?

Also, SU2018 is not officially supported on Catalina.

Thanks, but the files aren’t in there. I can see the files in the local folder on my desktop but whenever a create a new component it appears in the local folder but won’t

come up in the component window even after re-start. I am using SU 2019

If you select Open a local collection… in the Components browser, are you able open previously created/saved components?

1 Like

have you used non-SU default names for your folders…

john

The two ways that I access components is by the drop down menu under window/components. Then in that window I choose Open a local connection. The components that come up do not

match the components in the folder that sits on my desktop. I currently have about 23 components in the folder but the components window shows only 17. Go figure. Also some of the names do not carry over into the window. For example, in the local folder the name of a component might be Small Display but the window says component #6, even though I did not save it with that name. Confusing.

Not sure what you mean. I have named five local folders that sit on my desktop and hold numerous component files. The names on the folders are whatever. The folders are being

accessed ok by SU but retrieving the correct names on the component files and showing these component names correctly in the component window is the problem.

what I meant is SU uses these names for it’s folders…

"3d Printing", "Asphalt and Concrete", "Brick, Cladding and Siding",
 "Carpet, Fabrics, Leathers, Textiles and Wallpaper", "Colors",
 "Colors-Named", "Glass and Mirrors", "Landscaping, Fencing and Vegetation",
 "Metal", "Patterns", "Roofing", "Stone", "Synthetic Surfaces", "Tile",
 "Water",  "Window Coverings", "Wood"

in past versions of mac SU, using any of these for local folders was an issue…

but, now you have explained in more detail your current issue, I would suggest two avenues for investigation…

check the if any files are downloaded from the internet, check for x attributes and remove them…

this is one I downloaded today…

~/Downloads/Bars.skp: 
  com.apple.metadata:kMDItemDownloadedDate,
  com.apple.metadata:kMDItemWhereFroms, 

this will be blocked on macOS after Sierra unless you fix them… [there are posts on this]

the second point is component filename and Component name in SU are two separate things and do not necessarily match…

there are posts on how to align the naming and there may even be an extension to help…

john

1 Like

… and the Component Manager panel displays the definition name not the filename.

From the SketchUp application Release Notes for SketchUp 2017 …
… (the emboldened and underlined emphasis is by me) …

Standardized Product Content Locations

We have standardized where product content, stuff like collections of components, materials and styles are stored on the file system.

On Windows, we moved the default content that comes with SketchUp (Components, Materials and Styles) out of the Program Files directory and placed them in the ProgramData directory.
And on both Windows and Mac, we created Components, Materials, Styles and Templates folders for your user related content. By default, these folders are in the following locations:
Windows: C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp
Mac: Users/<username>/Library/Application Support/SketchUp 2017/SketchUp/

Note that if you store your content in these folders, it will show up in the Components, Materials and Styles browsers without you having to do anything and your templates will show up on the Templates pane as well.
Additionally, users no longer require special privileges in order to modify the contents of these folders.

So if you just put those folders in the (versioned) app support “Components” folder they’ll show up without having to (clunkely) add local collections.

A drawn back is that each year if your update, you’ll need to migrate these folders to the next version’s “Components” folder.

2 Likes

I have had this problem, try renaming the folder containing the components, then open it as a new local collection, should fix it… you could also try clearing the PRAM, sometimes works…

Thank you Ryan. Seems like a bug din’t you think? I’ll have to look up what PRAM means.

Thanks again

1 Like

Programable memory, Turn off comp, turn on while holding cmd+opt+p+r and wait until the screen flashes on and off once then release. Clears temporary app data… Ya its buggy, but on the list of needs fixin’ I think it ranks low… I think the above solution is the fix, haven’t tried it yet but will next time I re-organize myself.

I was successful with your advice of changing the local folder name before opening it in the component window. That solved the problem. I guess I will just do that after every new component addition which is not that big a deal. At least I now have a method! Thank you

John

1 Like