Component View in 2021

I have noticed that saving components does not show a preview view in my File Explorer anymore. I have view set to Extra Large Icons. This severely restricts my ability to preview the components for selection. Is there a changed process?

Are you saying you don’t see the thumbnails in the Components panel?

The thing with thumbnails in the File Explorer not showing up. Properly installing SketchUp or Repairing the installation seems to help. In either case this requires right clicking on the downloaded installer and choosing Run as administrator.

Yes, the proper name is thumbnails. I ran repair on the installer, but it looks like the SU team says they are still updating this release. Let’s see.


Are you seeing the thumbnails in the Components panel?

Yes, I am

I see the thumbnails in the component panel, but not a view of the component in File Explorer.

OK. So as I wrote before. This is an issue that has been reported. Some users have rectified the problem using the correct installation method which means right clicking on the installer and choosing Run as administrator.

Personally I prefer to save components and bring them into my model through the Components panel. That prevents them from getting double wrapped.

(Please disregard my comment about SU Team working on it. Seems that was related to another issue in Jan 2020).

I ran the repair option, but it did not allow me to get into administrator mode. So, I uninstalled and reinstalled Sketchup 2021 with a fresh download. I restarted the computer.

I have always preferred to preview my components which I have sorted in a MasterFormat file folder structure. If, I have to sort through the thumbnail outline, this would severely slow me down and I would have trouble seeing the finer details that the File Explorer allows so I can select the components I am looking for.

Is there a view option I need to set when saving the component that I have forgotten about?

When I installed I did it in Administrator mode.

Does that mean you logged into your computer as the system admin or you logged in normally and did I was said in my earlier post?

OK, let me see if I can respond correctly.
1- I went into my Settings/Apps and ran repair on Sketchup 2021. It did not allow me the option of Run As Administrator.
2- I downloaded a new ‘SketchpPro-2021-0’. I uninstalled and reinstalled Sketchup 2021 using ‘Run As Administrator’. I also went back and using this same file ran the Repair option As Administrator.
3- If you can see the file below, the lower images were created in 2020 and the upper images with only the SU logo are in the top row are from 2021.

And yes I am logged into my computer as administrator.

OK. So you did eventually get SketchUp installed correctly, at least.

And yes, this thumbnail thing for files created in SU2021 has been reported already. Hopefully it will get some attention and be fixed in the first maintenance release.

Do you always use your computer logged in as the system admin?

Yes, I always log in as administrator and install programs use “Run As Administrator”. I don’t believe the program was every installed incorrectly, but I look forward to the bug fix in the maintenance release.

Thanks for your input!