SketchUp 2021 Files Don't Display as Thumbnails

They display as the icon. Any idea why? I do have folder options set to display as thumbnail. Thanks!

1 Like

Can you say exactly what the Windows view setting is? I don’t see a thumbnails option, but there are several other options. Small icons, List, and Details, won’t show the thumbnail. The other options do.

Large Icons. The files with thumbnail images were created and saved in 2020 or earlier. The ones with the new SketchUp logo icon were created in 2021.

3 Likes

and if you look closely, you can see @DaveR’s secret versioning method :slight_smile:

I just noticed this today too. I usually use Details view for all my folders but today I went looking for a component and turned Large Icons on. Every other SU version had created thumbnails but not 2021.

I thought I had remembered something from the release notes, and I have found it now.

  • (Win) The SketchUp installer’s “Repair” option has been improved to better handle some problems such as incorrect file associations and missing thumbnail icons.

It would be worth trying a repair, and see if it does fix missing thumbnail icons.

Had the same problem, thought that this feature maybe would’ve been dropped with SKP2021, just stumbled upon this thread by accident. Repairing the installation solved that problem. :ok_hand:t2:

Thanks for the responses. Large icons didn’t help, neither did repairing the installation. I wonder if different versions have that magic repair?

Repairing the installation didn’t work for me, either.

1 Like

Has there been anything further on this issue? I’ve tried all of the above, including uninstall and reinstall, yet nothing has worked. If I want to see the thumbnail, I can ‘save as’ a 2018 or earlier SU file, BUT when it is saved as anything earlier than 2021, all of the neat features from SU2021 disappear…:frowning: Really glad if there was a fix for this…

the guys scripting the installer which needs to write the appropriate keys to the Windows registry need to fix this. I’m not sure why this is still an issue since 2020, shouldn’t be rocket since.

Hi Dave,

How do I run a repair? Ive noticed these thumbnails not showing since installing 2021 and I would like to try the repair method to see if it fixes it on my machine… Can let you and everyone know whether it worked or not.

Cheers Wolf

The repair to SketchUp is done by closing SketchUp and LayOut if they are open. Then find the downloaded installer (get it from sketchup.com/download/all if you haven’t done so in the last day or so.) Right click on the installer and choose Run as administrator. If prompted, choose Repair.

This may or may not sort out the thumbnails but if you didn’t use Run as administrator when you installed SketchUp in the first place, it’s still a good idea to do it. And it’s like chicken soup. It couldn’t hurt. :wink:

Good luck.

Morning Dave,

Thanks for the info on this, unfortunately it hasn’t changed the 2021 logos back into thumbnails on my machine either. Only a small issue, however very handy when scrolling through a library of products to be able to see the thumbnail image. Hopefully Team SU get a new Chicken Soup recipe sorted…

Cheers Wolfgang

1 Like

Hi all,

I don’t really have much to contribute other than I’m experiencing the same issue with all 2021 skp files, even after a fresh “run as admin” install. One weird thing I noticed is that when right clicking (on a 2021 skp file) > Properties > General > Opens With says “SketchUp 2019” but with a 2021 logo (even after I’ve changed it to point to SU 2021). Despite this, when I actually double click to launch that same skp, it does indeed launch in SU 2021. Having the thumbnails is really helpful, especially when teaching new SketchUpers the value of a components library, so I hope this is fixed soon.

Please fix this problem. I’m saving all my files in 2018 format to avoid this thumbnail issue. But indeed, as said by others, we lose the layer/tag folders in the process when I reopen the files in Su 2021…

1 Like

Same problem here (Win10, build 19042 SU 21.0.391). Tried repair reinstallation, still no thumbnails.

Saving as Sketchup 2020 brings thumbnails back… Please fix it asap!

You may find some solutions here, it works well for me…

That sound like whole lot of hassle just to (maybe) fix this issue. Imagine you have to do this on every computer in your office… (I tested 3 computers, all have this issue).

Besides - why does saving to 2020 format produce thumbnail and 2021 does not? Clearly there is something broken there.

Is there anyone that upgraded to 2021 and can actually get thumbnails working when saving to 2021 format?

Possible fix:

Removing older version (2020 in my case) and doing Repair reinstallation of 2021 seemed to magically fix the problem (without the need to use registry editor or reboot).

1 Like