Sketchup file shows preview and size in files, but opens completely blank

Probably the camera is screwed up. share the .skp file so we can see if we can fix it for you.

I just tried to upload and the file doesn’t show up! But - if I do a search, it’s still there…???

Too large to upload directly to the forum. Upload it to DropBox or WE Transfer and share the link.

Make sure you are uploading the .skp not .skb file.

It’s uploading now and says it’s going to take about 20 mins…

780 Mb is a large file.

Which is odd because it’s not a big model…

From the image you show it lookks like a bunch of entourage. Probably excessively detailed.

I’ve worked on huge building models that haven’t been that large. This is just my own little condo. Bizarre.

I expect there’ll be a simple reason for it. I’ll look in the process of fixing your model so it can be seen.

I’m just seeing that there doesn’t seem to be a .skp file - only SKB.

I wonder where the .skp file went. Well, upload the .skb instead, then.

Alright. Let’s see what we see.

Well, as it turns out there are no objects in the model. Both In Model components and Outliner are entirely blank.

I wonder if you had inadvertantly hit Erase when you meant to hit Hide in the Context menu.

There are tons of materials, though. 640 of them.

Many of those textures are rather large.

But not one of them is actually used in this file. Purging unused materials eliminates all of them and the resulting file is only about 12 Kb.

Upload the AutoSave_Hawthorne file. Let’s see if there’s anything to recover there.

Unfortunately there is no Autosave for this particular file, and I haven’t opened it in a long time. This is the only one it could be - showing as a TMP file.

What about these?
Screenshot - 6_4_2023 , 4_24_51 PM

I’m uploading that to WeTransfer now…It too wasn’t able to be uploaded here.

There’s a 16 Mb limit here. Your files are many times too large.

Those are different files - much earlier iterations.