SketchUp File Corrupted? Not Saving to Trimble, Extensions not working

Gramercy Remodel 48" Range Sketchup copy.skp (4.2 MB)
An extension (GKWare Cab Maker v9) no longer works with this model, and I’m unable to upload the model to Trimble Connect. I deleted the most recent items brought in from 3d warehouse and purged unused. “Fixed Problems” does not show any issues. Saving a copy and renaming has not helped. When I open SketchUp the files with these issues do not have a thumbnail but rather a white screen. I’m still able to open and modify the file. My SketchUp File can be saved locally but when I try to upload it to Trimble Connect I get a “1 File failed to upload” message. An older verson was able to be uploaded with no issues.

Any help would be appreciated!

Are you still using SketchUp 2021 as indicated in your profile?

I fixed incorrect tag usage. I notice that you didn’t have Untagged active which you should.
Screenshot - 6_26_2024 , 1_50_43 PM
Purged unused stuff, unlocked the locked objects and then saved it to Trimble Connect. It went just fine. I don’t know if it’s one of those things or maybe a connection on your end?

As for GKWare Cab Maker not working, maybe maybe @gkernan has some thoughts.

I downloaded your model (the unfixed one) and cabmaker 9 works fine with the model.
However I don’t have your resources - rules, doors, materials etc.


PM me and we can figure your issue out.

1 Like

Hi Dave! Thank you so much for looking into the model for me!
I am running Version 24.0.554
I made the untagged active and unlocked everything. I do not know how to fix the incorrect tag usage in a more universal way than selecting items and retagging. Can you walk me through the steps to do so, where you are able to see that Default Tag Geometry screen?

Unfortunately even after having untagged active, unlocking everything, and trying to purge it is not purging anything and still saying nothing no problems found.

@gkernan has always been super helpful with extension help, will reach out after I get this model sorted. The extension seems to be working with other models I have saved so I think the issue is with this model and it’s copies.

Thank you Greg! I really appreciate your help. I’ll PM you if I can get this model saved. It sounds like it might be a model issue and not an extension issue but I will reach out!

Please update your forum profile.

The Default Tag Geometry window is the report created by an extension called Default Tag Geometry which is available from Sketchucation. It goes through the entire model or your selection and removes tags from the edges and faces.

I didn’t bother with a validity check on your model before uploading it to Trimble Connect. As I wrote, I don’t know if any of those things have anything to do with my ability to upload it. TBH, I didn’t try before.

Try saving the file on your internal drive and then quit and restart SketchUp. Open the file again and try saving it to TC.

I wanted to update this thread that a work-around seems to have solved my issues.
I uploaded the file to Google Drive, my business partner downloaded it and was able to upload it to our company Trimble account. I deleted the file on my computer and downloaded from Trimble. Everything is working again, including GKWare Cab Maker (thank you @gkernan for your reply). I have no idea why this worked but glad I tried.

Thank you @DaveR for trying to help me resolve!