SketchUp failed to open project

hey
i’m working on an important project on SketchUp When I close the file and reopen it, it shows me a tab can’t open the document
I really need the file and I don’t know what to do
please help me

1 Like

SketchUp 22_04_43 09_48_18 ص

Change the .skb to a_new_name.skp, that opened for me. then invest in Skimp (trial) and drop those components to a more useable size, especially considering the scale.

1 Like

If the data is important , one needs to be responsible. That is, create backup’s at appropiate times or do ‘Save as’ for version history.
Preferable, one might have multple backup-systems, one hard copy on a local machine, one on aother located drive and one ‘in the cloud’.
btw. it opened fine on my 2015 Mac, but the file seems to be a little bloated.
There are more efficient ways to deal with high poly objects for render purposes. (and more efficient ways to model, I suppose)
But my guess is that a lot of it came from somewhere else.
This book, par example has a lot of unneeded geometry:

Mind you, SketchUp only uses 1024 px of an imported picture or texture, there is no need to have textures of small objects in the render to be 3000px wide.
Might be that names like this:

can increase troubles by 68% :slight_smile:

https://app.connect.trimble.com/tc/api/2.0/s/762UPSHlbsToyT3KVyVYTqwTI8R8v546T_5S5UtEyQsXEdUGw0i2JHK7JHXCBf8d

1 Like

Thank you, I was in a hurry and I did not notice the backup of the file.
How can I open the files because the link is invalid to load?

I downloaded it and the problem still exists…
SketchUp 22_04_43 09_48_18 ص

clicking on the hamburger menu on the right should give you the option to download it.
I suspect some weird naming causing issues on the windows platform, still.

1 Like

yes, I download it and it’s still failed to open
what should I do now? I really need this file…

Did you understand and try this?
It looks like the file you are trying to open is the .skb not the .skp (note the difference in the file extension)
Is this the case, are you attempting to open a file with .skb at the end rather than .skp?
If so, either find the correct file which should be .skp or make a copy of the .skb and rename it to something.skp and try opening that.

yes, I did that… I open the skp and I tried to open the skb of the file by changing it and the same problem still shows

I was able to open the original .skp. Try this one:

2 Likes

Your file is huge. It would help if you purge unused stuff from the model. It’s also a good example of file bloat due to excessively detailed entourage. For your next project, take the time to clean up the components before you add them to your model.

A couple of examples here. These could be put on a diet and reduced quite dramatically without affecting their appearance in the model.

No need for most of the geometry inside the red box.

Nor any of the geometry on the bottom of the carpet or the ottoman.

Or most of the geometry on the underside of this sofa.

If you get in the habit of cleaning these things up as you are modeling, you’ll find your models easier to work with.

3 Likes

the sketchup file can’t be opened after I save and close it. can you please advise

Hi I cannot open the file, is there anyway you could help to open it? thanks

About 90% of the file is filled with zeros. Do you have an SKB file in the same folder as the SKP?

Hi Colin, thank you for the quick reply. here is the skb file

That one is about 30% filled with zeros. It would not be possible to recover anything.

Do you have any sort of backup system, where you can check the state of a given folder to see what the contents were in the past? Windows has a built in versions feature for keeping versions of your files. If that is turned on you can get Properties on any file, and look in the Version History tab to see if there are recent versions of the file.

I don’t have an external drive to have tried that myself. Here is Microsoft’s article about the feature: