SketchUp.exe - Bad Image (error status 0xc000012f)

I’m at a loss. I’m getting this error upon trying to open all things SketchUp (Pro 2022, LayOut 2022, Style Builder, Sketchup CheckUp):

Sketchup Error

I have scoured the internet for answers and narrowed down that this is likely an issue with some bad communication between my OS, Visual C++ Redist and/or .NET Framework.

I just built this computer, it was setup with Windows 11 and upon first turning it on a few weeks ago I was able to download and run SketchUp Pro 2022 with no issue though I only pulled it up for a second to check it. So what changed? A few days ago I did an entire computer case transplant to fit a new graphics card (NVIDIA RTX 3070) where I had previously just been using intel HD graphics.

That is the only thing that changed, but this issue doesn’t seem to be with a GPU driver.

Operating System: Windows 11 Pro 21H2
CPU: Intel i7-12700k
Ram: 64GB
Storage: Plenty

What I’ve tried:

  • Complete uninstall and reinstall as an administrator of SketchUp 2022 (about 3 times at this point.)

  • Version Checks of both Visual C++ (2015) and .NET framework (4.8.*)

  • System File Check scan, to no avail

  • Complete repair install of Windows 11 Pro

  • Following a blog post I also tried to re-register (cmd regsvr32 “filepath”) the troubled .dll file and got this

A point that I noticed during all of this is that in my file explorer, where on my previous device running Windows 11 Pro I had a Program Files and a Program Files(x64) folder, On this device I the other folder is Program Files(x86)… I don’t really understand the difference in architecture but this is the first time I’ve seen the (x86) - I don’t know enough to know if that’s important.

Thanks for any help you might be able to provide.

Try repairing Windows, YMMV

Already done, twice, Once with current updates and once rolled back to the original install version on my thumb drive. - No luck.

Have you tried uninstalling and reinstalling the C++ and .NET framework packages?

I did completely uninstall and reinstall the C++ package. But from what I have found online, Windows 10 and later you are not able to uninstall the .Net Framework.

Some additional reading lead to a possible lead. Since the last time I had SketchUp working I downloaded the Steam gaming client for some off-hours enjoyment. Apparently that client can potentially meddle with the .dll framework and cause some conflicts. I am going to try purging my system of the Steam client this afternoon and see if that maybe helps.