SketchUp 2017 Checkup program error


#1

When I run the program I get this error message in the log:

Error: Your “GeForce GTX 960/PCIe/SSE2” graphics card has 1 MB of graphics card memory. SketchUp requires a graphics card that has 256 MB or more of memory.

I have updated drivers and everything on the card tests perfectly in other testing software. In fact, here is the info on the card from the driver test:

[Display]
Operating System: Windows 10 Pro Insider Preview, 64-bit
DirectX version: 12.0
GPU processor: GeForce GTX 960
Driver version: 376.33
Direct3D API version: 12
Direct3D feature level: 12_1
CUDA Cores: 1024
Core clock: 1304 MHz
Memory data rate: 7010 MHz
Memory interface: 128-bit
Memory bandwidth: 112.16 GB/s
Total available graphics memory: 12279 MB
Dedicated video memory: 4096 MB GDDR5
System video memory: 0 MB
Shared system memory: 8183 MB
Video BIOS version: 84.06.26.00.61
IRQ: Not used
Bus: PCI Express x16 Gen2

As you can see, I have 4 gigs of RAM and 12 gigs of useable memory…so why does Sketchup think I only have 1 meg???


#2

This is a known problem with the Windows system analysis call that SU uses to find out what graphics you have. Provided there aren’t other OpenGL issues, it should not stop SU from running.


#3

The instruction page where you downloaded Checkup, answers this quite clearly, in the note box, under “Error 6.”

http://help.sketchup.com/en/sucheck


#4

Why is done and acceptable??


#5

Huh?!


#6

[quote=“DanRathbun, post:5, topic:36542”]
Why is done and acceptable??

Huh?!
[/quote] Lost in translation.
Please rephrase @mac7595


#7

I was trying to be : “nice”;
I was wondering why SU management would even allow the release of buggy program that is suppose to help the user and then burry the problem is some obscure release note. It smacks of MS in the old days when they used the users as regression testers.


#8

Not where I got the software…thus never saw that… but thanks!

Greg


#9

And it is also Microsoft now, as the bug is in Microsoft’s System Info utility. Microsoft acknowledges that there is an issue with that utility, but has not fixed it, and not said if they will fix it. (Which since it’s been bugged since Vista, will likely NOT fix it.)

Darned if you do, darned if you don’t.

In most software revision cycles, there comes a time when the code must be frozen, in order to meet some management rollout target date. So, sometimes, things do not get fixed, in time for release.

This happened here. What was done, (for release) in response to the MS utility error, was to relax that graphics memory requirement, in SketchUp’s startup cycle (which uses a subset of the Checkup code.)

But it was too late for the Checkup utility, to be fixed.

It is not. The issue has been logged. But, as is usual, after the main SketchUp release in November, most of the team goes on vacation, after busting their butts all summer long.

The serious work on the major maintenance release(s) usually begins after the new year holiday break, and comes sometime in late January or in February. (Even though, this cycle, we got a quick first MR, released soon after the initial v17 release.)
This is how it has always worked since Trimble took over and the cycle gradually settled on a November release with versions 2013 through 2015.

So, expect ongoing maintenance, like any software utility.

Just FYI, I did a search and found a Microsoft page that gives sample code for getting graphics driver information direct from a WDDM (Windows Display Driver Model) compliant driver, using one of the Direct-X graphics libraries. I gave this information to the team member responsible, and he added the link for this MS example, to the issue ticket. (But this information was found too late to affect the released utility.)

So, we’d hope that in the next month or two, a revision will be released, that fixes this, and other open issues (UI readability, etc.)

Because, the consumers in most western countries, have allowed and somewhat expect, that products (especially software) to have flaws right “out-of-the-box.”

So, partly it is the consumers fault, and partly the fault of western product managers and marketing, and well partly “Mr. Murphy’s” fault.

(Playing devil’s advocate here,…) IF they had NOT released a check utility, and instead forced users to go through a technical online document that explained the more stringent requirements for SketchUp 2017, … what would have happened ?

Most people would not have thoroughly read the document, nor even if they did, understood whether their system met the requirements. (We get this now from people who do not know that the utility exists. They do not read the requirements page, or know what it means with respect to their own system. They just waste the time downloading the full application and attempting to install it on sub-par systems.)

So, … they’d have been bitchin’ for a utility that checked their system anyway.


In conclusion, does anyone LIKE the fact that the utility is currently partly flawed ?

I think not.


#11

I’m not making excuses for them, because I don’t like the result either.

I’m just saying how and why things are.

I agree that it is goofy to have a check utility that is flawed.

Yes because it likely does not use the MS Info utility.

It is Windows. And the “flaw excuse” says “Microsoft” so it certainly doesn’t imply Apple OSX:

Note: We gather data on your graphics card memory by querying Microsoft’s System Information. On some cards, what Microsoft reports is incorrect. This can cause Checkup to issue this error falsely! The presence of this incorrect result will not prevent SketchUp from running.


#12

Sorry, I apologize I read different message in your post.
BTW the Msinfo call does work on my machine, W7 64 bit but, msinfo is no longer shown in the command list , the correct call is msinfo32 and it does work fine??


#13

Yes that is the name of the utility executable file.
I do not understand what you are asking about it.