SketchUp drawing drops off screen

I have SketchUp Pro 2016 on 21.5-inch late 2012 iMac. Recently upgraded to OSX El Capitan Version 10.11.2. I have 8GB of memory and currently plenty of spare capacity.
Lately, when I am drawing simple architectural details in SketchUp the drawing suddenly disappears from the screen. I retrieve it from Finder but when I try to use the drawing tools: Arc, Line, Tape Measure etc, the drawing disappears from the screen. It does not shrink onto the dock bar - it just disappears and can only be retrieved from its folder.
The drawings are filed in Dropbox and I have sufficient spare space in my allocation.
There have been a host of small niggling problems ever since I upgraded (hah!) from SketchUp 8 Pro and from whatever the predecessor of El Capitan was, but this is a serious problem which is preventing me from carrying out my work and costing me time and money.
Help!

By “the drawing disappears from the screen” I assume you mean that the view window goes away, leaving behind the menu, tool palettes, and inspector windows? Do you have multiple virtual desktops (aka “spaces”) set up on your Mac?

If so, this sounds like a problem that has been reported several times and seems to be somehow related to having multiple virtual desktops or multiple actual displays. At this time there is no known fix, just avoidance strategies. Assigning SketchUp to a specific desktop via the right-click option menu on SketchUp in the Dock and unchecking the “Automatically rearrange spaces based on most recent use” box in System Preferences->Mission Control can minimize the chances (you can still have problems if you drag a model view onto a second desktop from the one where it opened).

1 Like

Thanks Steve for your prompt reply. No, the entire SketchUp window including menu toolbars etc disappears, leaving just the iMac screensaver picture. No, I don’t have multiple virtual desktops set up.
The puzzling thing is that it doesn’t happen to all files, just a few (so far, I hope). This particular file is only 2.1MB. I cleared a lot of photos from my Dropbox folder, freeing up a lot more space but it didn’t make any difference. Oddly, the Autosave backup of the same file is not experiencing the same problem, so I am able to work on it and have only lost a small amount of input. This may be a clue: I have noticed that the top bar above the Toolbar - the one that has the Apple icon, SketchUp File Edit View Draw etc - is not visible until I run the cursor up to the top of the screen. This seems to occur only with these disappearing files. Perhaps an indication of a corrupted file?

you are running in ‘full screen mode’ if you can’t see the in the menu bar…

SU works best if assigned to a single desktop/space and isn’t in ‘full screen mode’…

this is also true for other multi document, multi window apps on a mac…

Dropbox.app also causes problems for Autosave and Backup files…

it is better to work from local files and send to Dropbox as a separate action…

john

Hi John
Thanks for the solution. Such an easy fix, bit embarrassing really. Thanks also for your sage advice, It’s much appreciated.
Regards
Bill

The shifting of spaces (to the desktop next to it) in fullscreen, with certain actions

, is back. I have read in several threads that it comes back with some Apple updates, and that its Apples fault. I think Sketchup should let them know its back again. Here I try to close the file while there apparently is sketchup text in edit in another space, causing an erratic shift back and forth between spaces that is probably very confusing if you have not seen it before. Cool effect though. Not going to fullscreen is the fix until it gets sorted out again :slight_smile:

Yeah, Apple doesn’t appear to have Big Sur fully shaken out yet even after a couple of revisions. It mostly works, then suddenly fails to do something that used to work. A lot of regression errors.

I have an external number keypad that I’ve used with my laptop instead of constantly reaching up to the keys. Under Big Sur it sends every number 5 times when you press a key! They blew some things in bright mode with how they implemented dark mode. For example, if you click a menu item in safari, it turns white on white until you float the cursor over it a second time. Little stuff that worked under Catalina and now glitches. It is as if they want to be Microsoft.

I haven’t seen anything like that before. Switching between spaces can be done with Control-left or right arrow. Is it possible your keyboard has issues?

The issue is an involuntary switch between spaces. In full-screen mode it seems there is some confusion in regards to which space sketchup belongs, , and I guess that action triggers going back to the space sketchup left when going full screen.
So when I start typing while applying a leader or a text in sketchup then suddenly the space is shifted to the one left or right from it. From here I can finish typing, hit enter, and that provokes a side shift of spaces back into sketchup.
I remember that thing happened in some early version as well, some 10 ears ago. From the forum posts, it seems there were uissues of the sort around 2016 as well. The fix for me now is to not go full screen. Last time it got fixed with fiddling about with the settings in the right click menu of the program symbol, where you can “assign desktop” under “options” Those 2016 posts also point to the assign desktop fix…
I can also work fine in fullscreen without the sudden side shift IF fullscreen was in use while I last closed Sketchup.
I can recreate the issue consistently with only the actions described above, and noe other space throughout the Mac environment so I don’t think its an hardware issue.

It came with the latest Big Sur update, and was not there before, and is not present anywhere else on my system.

Last time it creeped up was a few MacBook Pro´s back in time

I can happily report that with todays Big Sur 11.2.2, all those strange things went away. Also the BugSplats, so far.

Big Tech works in mysterious ways, and look after each and every one of us.