Jumped to home screen when working in a basic drawing

When working on my Mac book pro using Apple mouse. I get to a halfway point on basic drawing trying to add detailing it doesn’t matter whether I am copying or moving or extending my component. The page I am working on slides away to the right and I end up on my home screen with the icon I was using in the centre of it!
I have played with the sensitivity of my mouse and I’ve turned off nearly all of the mouse operations but the basic!
Maddening can anybody offer any help!!! Thanks in advance.

have you Assigned SU to that desktop?

it helped for me…


It sounds like you may be activating a shortcut on your mouse to show the desktop. Try editing your Mouse preferences and turning off the Show Desktop shortcut.

I really struggled with the “gesture” system with the magic mouse. I ended up not using it because of just what you are describing… that and hand cramps (too low a profile for me!).

I’ve seen similar issues on my MacBook Pro Retina. They appear to result from opening SketchUp on a different desktop than it last used. That is, closing the model without quitting SketchUp, changing to a different desktop, and then reopening SketchUp by clicking its icon in the dock. As John suggests, assigning SketchUp to a specific desktop has so far stopped this from happening to me again.

Thanks for feed back both tips have worked .

Hi, thanks all for the tips. I have the same problem when in fullscreen mode: sometimes, for no specific reason, SketchUp moves to another space. It is still active in the menu bar, the current tool is still selected but the window remains in the previous space.
As fullscreen apps move to their own space, there is no way to control the behaviour.
Disabling Mission Control keyboard shortcuts or gestures does not resolve this problem.
Workaround: don’t use SketchUp fullscreen …
Please Trimble do something about it. Fullscreen mode is great on portable Macs !

Keep making great software :slightly_smiling:

OS X 10.11 (15A278b), SketchUp 16.0.19913

I found that unchecking

Preferences->Mission Control->Automatically rearrange spaces based on most recent use

also helped. I think SketchUp gets confused when the spaces are renumbered based on use!

Just verified, It does not help :frowning:
I think I found the cause: Everything is ok until I open a palette like the outliner before or after going fullscreen.

This happens to me too. I tried all three fixes recommended previously in this thread. It’s a serious issue for those of us who have it.

Hopefully Apple will get a fix going soon.

Did anyone find a fix for this? I’m about done with sketch up based on this bug. I’ve tried all suggested fixes and nothing. I can get it to recreate this every time when I use the 3d shapes helix. It’s making sketch un workable. I paid money for this buggy ass program

Did you ever figure out a fix?

Any luck?

I don’t work for Apple and it appears it’s a thing they needed to fix. I haven’t seen any recent reports of it so maybe Apple did fix it.

No such luck. Thanks Dave. Now I remember why I quit using this program

You quit using SketchUp because Apple had a bug in their operating system? Weird.

1 Like

I quit using sketch because i couldn’t find a work around to it jump to my home screen every time I tried to use certain tools. It’s not just the helix tool. Its instability with open faces and other known sketch issues leave a lot to be desired for me. I was offered a 3 year free subscription to fusion 360 and never looked back. That is til my 3 years ran out

Well, whatever. Happy trails.

You seem like a developer that is a little jaded that I’m poking at your code. WTF? Why so defensive?

well then why the hostility? My MacBook is from 2015. I’m rockin sketch up 2016 pro. Which means my chicken came before sketch ups egg. So isn’t it on trimble to make it compatible with that operating system. How is it Apples responsibility to make other peoples code compatible?