Models keep moving

I’m new to SU and am using a 2015 MacBook pro with the latest Sierra. Here’s the problem: When creating designs for furniture I find that the model often moves off the page when I click on a tool–especially Push/Pull, Move, Orbit. I often have to restart with Zoom Extents and Iso. What am I doing wrong? And is there any way to stop this?

This might be the solution you need.

Thanks for your idea, but I’m afraid it didn’t work. The model still drifts off the screen. Some more information about my computer setup, here’s what I’m running:
Sierra 10.12.6
Processor 2.8 GHz Intel Core 17
Graphics AMD Radeon R9 M370X 2048 MB Intel Iris Pro 1536 MB

I also run an additional screen with the MacBook pro.
Hope this additional information will enable someone to offer a solution.

If I understand your post correctly, you are referring to a different situation than what I discussed in the topic @Box linked. In that case, the issue was that the view window would jump to a different virtual desktop (aka “space”) leaving SketchUp’s “chrome” (i.e. menus, toolbars, inspector windows, etc.) on the original space. It sounds more like the view window stays on the display where you had it, but the model contents move in that window. Am I reading you correctly?

Edit: could you share your model here so we can see if there is anything strange about it?

What are you using for an input device? Mouse, Magic Mouse, Touch pad?

Yeah, it’s Mac so beyond me, but it looked familiar.

Hi Dave,
I’m using a microsoft wheel mouse with a USB cord. I also have a magic mouse that is on.

Turn off the magic mouse and see if that helps.

Thanks Dave.
I’ve shut off the MagicMouse and this helps a lot. The model sometimes drifts a bit, but it never scoots off the screen–or at least it hasn’t yet. I appreciate your help.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.