SketchUp 2016 Mac Problems

I don’t mean to be dramatic, but SketchUp 2016 for Mac is a nightmare. It keeps doing this weird thing where when I go to take an action, anything from drawing a line, to scaling to moving something the window I’m working in slides off the screen. I have to keep quitting and reopening in order to do anything.

Another issue is that updates to scenes and styles is not sticking. For example, in a particular scene I have checked the ceiling layer, updated the scene but every time I go back to that scene the ceiling is off.

Very frustrating and I never had these problems before. I reinstalled it but that didn’t fix anything.

Has anyone else experienced this and found a fix?

one I prepared earlier…

this has helped others and a search would have found it…


thank you for the reply. i don’t have that option.

Is the “visible layers” option checked under “Properties to save” in the Scenes tray (or the Mac equivalent)?


As John posted, several people (including me) have seen this happen, but the exact cause isn’t known. In the other cases I know of, it has always been related to multiple displays or the virtual equivalent multiple desktops. It happens to me when I have SketchUp open on one desktop, close the last model (on a Mac this doesn’t quit the app), and later click the dock icon to reopen SketchUp in a different desktop space. SketchUp then gets confused about which desktop should have the menus, etc. vs where you opened the model. Very annoying!

Turning off Preferences->Mission Control-> Automatically rearrange Spaces based on most recent use, and setting the Option as John suggested have kept it from happening again on my MacBook Pro Retina. But if that option is grayed out or missing on your Mac, I don’t know what to say…

can you fill in your details better, i.e. version of OS X…

it may help us help you…


Thank you. I have just unchecked this option in mission control. i’ll see if that does it. i don’t know why i don’t have the other option in my dock. i only have “keep in dock, open at login, keep in finder.”

the OS is El Capitan version 10.11.3. It’s a 21.5" iMac, late 2012)

Memory: 16 GB 1600 MHz DDR3

Processor: 3.1 GHz Intel Core i7


yep. i made sure to have that checked.

if you use LaunchPad to start SU, do you then get the ‘Assign To’ option?

there was and old bug if you ever opened an app with Spotlight it’s option would vanish…

This all assumes you have more than one ‘Desktop’…

Running in ‘Full Screen’ mode from the main desktop may not have the option…


I have the same problem using a MacBook Pro and Cinema Display. When I click on a point in SU, it slides away to a new screen which it creates. Mission Control shows that it has created a new screen, but there is no obvious way to close it.
SU is unusable in this state.
I did not see a solution in this thread.
Any additional suggestions would be appreciated.

Under some situations, SketchUp has trouble figuring out which desktop/display should receive the model edit window vs the “chrome” (menus, palettes, inspectors, etc.). For me, this most often happens under one of two situations:
a) I close the last model window but don’t quit SketchUp and then later open another model after changing to a different desktop. This case can be avoided by making the settings discussed in earlier posts in this topic.
b) I open a model window on one desktop and then drag it onto a different one.

In both situations, if you drag the model window to the space where SketchUp “jumps” you can get body and soul back together again (until it happens again).

Thank you, I appreciate your advice. I will try what you suggest, but I think the cause of my problem is different. This happens when I reboot my Mac, open a SU window and start. I do not open and close anything and I do not drag anything.
SU simply jump to a new window which does not let me work in it.

Hmm! Hadn’t heard of it happening after a reboot…that suggests that SketchUp is keeping track of which desktops it has used, but I don’t know where or why. Please let us all know if my suggestions work for you, so that we can spread the word if another user turns up with this problem!