SketchUp takes over every Space (Desktop) on Mac OS [resolved]


#1

Most apps on my Mac stay on the Space they were first opened on. For those who don’t know, Spaces are what Macs use to organize multiple desktops. SketchUp wants to stay on each and every space/desktop. Do other Mac users see this behavior? I’d prefer SketchUp stays on one space.


In OSX, the desk swaps alone
#2

Not me, but I’ll turn on Spaces for the rest of the day with Yosemite. I think I see external monitor on your toolbar? I don’t right now… just trying to compare similar.


#3

I just tested out on another account on my machine and DID NOT see the same behavior. I’ll turn some extensions on and off and report back.


#4

I run multiple spaces on Mac Yosemite and have never seen SketchUp do that.


#5

I deleted all the cache and preference files, disabled all plugins, restarted, etc… and the problem is still there. It is really quite strange. Maybe a reinstall will save the day?


#6

Click and hold on the SketchUp icon in the Dock. Select Options on the menu. In the bottom part of the menu, “Assign To”, you will see that “All Desktops” is checked. This Options menu uses “Desktop” to mean what you called “space”. Choose either “None” to let SketchUp appear on whatever Desktop is active when you open it, or “This Desktop” to pin it to the current one.


Models keep moving
#7

God bless you Steve. That was the issue.