Sketchup diffusion icon not showing after the install

Hi, My Sketchup Pro 2023 diffusion extension icon simply vanished after clicking on it, so I tried re-installing it. The installation has worked as I can see it in my extension manager window, but I am getting a message saying it’s not been loaded, as follows:
‘‘The extension has been successfully installed, but was not loaded. To load it, go to the Extension Tap of the Preferences window and check the box next to the extension.’’
There is no extension tap of the preferences in my sketchup, and I have confirmed unrestricted access to extensions in my extension manager setting menu. I tried closing and re-opening sketchup - this hasn’t worked. Can you please help?
Thanks. Dana

This message is old and should have been changed with the releasee of SketchUp 2017. With that release the manager received is own window rather than being a sub-tab of the Preferences dialog.

So, the messagebox should say:

“To load it, go to the Extension Manager and Enable it using the switch to the right of it’s entry in the list.”

The manager no longer has checkboxes. They are big slide switches:


@colin I cannot get this old messagebox to appear on 2023 or 2024.

Is this somehow a Diffusion specific messagebox that parroted some old pre-SU2017 interface or example code ? (If, so the Diffusion team should change the message.)

I can ! I’m used to seeing it, even if because of you I realise I never really read it (with my brain turned on) :sweat_smile:
(during training, I’ll often uninstall / reinstall something like architexture to show them how it’s done and so they can write down a step by step. I usually show how to deactivate, then how to uninstall then how to reinstall)

in order to see the message appear, pick an extension that is installed on your machine, deactivate it. then uninstall it.
and immediately reinstall it.

since you haven’t restarted sketchup, it seems to know that the extesnion was deactivated, therefore it installs it already deactivated.

and you get the aforementioned message, here in french, fresh from the oven

Capture d’écran 2024-04-15 à 18.46.41

Hello and thank you for trying to help.

I deactivated the sketchup diffusion extension and uninstalled it and then immediately re-installed it.

Unfortunately, no luck – still no diffusion icon seen in the sketchup.

Any other suggestions how to fix this please? I tried shutting and opening sketchup too – no difference I am afraid.

Thank you.

ok, there was a misunderstanding here, that, the thing you did and I described, was for Dan and Colin, it’s a way to see the specific message appear.

well you’ve disabled all your extensions, so off course they won’t work.

you need to enable all your extensions. and at the bottom right, apply the changes.
Dan even showed you how it looks like

Oh my apologies, I have in fact enabled the extensions needed and they are loaded correctly but for some reason, the diffusion icon/bar is still not showing on my sketchup screen. I’ve tested the /disable/enable on all other extensions and it works, but it doesn’t work on the diffusion extension. It just makes no sense to me.

Enabling the extension in the Extension Manager does not make the toolbar show. Did you turn the toolbar on in View>Toolbars?
Screenshot - 4_16_2024 , 6_11_32 AM

Please cleanup your forum profile. Put the SketchUp version number int he SketchUp Version field, the operating system in the Operating System field, and the graphics card model number in the Graphics Card field.

1 Like

Can you see “Diffusion” in the Extensions menu?

1 Like

OMG, thank you so much Dave, your instructions have worked. I knew it was something silly but didn’t realize I had to go to the toolbars menu to make it visible. Problem solved and many thanks again!

Have a nice day.




Now please fix your forum profile.

Thanks Dave, I created my forum profile yesterday - is something wrong with it if it requires a fix please?

Yes there is.

The SketchUp version would be something like SketchUp 2024 or SketchUp 2023.

The operating system would be Windows 10 or Windows 11 or some version of the Mac OS.

The graphics card model number would actually include a manufacturer name like Nvidia or Intel or something and a model number.

Look at my profile or that of @ateliernab for examples.

I’ve made changes to the profile, hope it’s OK now?

Whaat is the graphics card model?