SketchUp crashes on launch


#1

SketchUp crashes on launch consistently. Just downloaded the installer and updated my NVidia driver today (Feb. 2, 2015). I submitted a Bug Splat for the first crash and didn’t bother for subsequent attempts.

Lenovo Thinkpad T520
Windows 7 Home Premium 64-bit (Build 7601)
NVidia NVS 4200M
Intel Core i7-2640M 1.8 GHz

I tried running with Intel Integrated Graphics, but that didn’t work. Since this is a laptop, I also tried plugging/unplugging and turning the power settings up and down in case that altered the GPU’s behaviour. (I don’t know for sure that it’s a GPU problem―Just guessing!)

Thanks,
―Chris


Can't launch SU anymore
#2

Hi Chris-

I found your bug splat report and it seems like SketchUp is crashing when trying to initialize a web browser window. Does Internet Explorer run on your system, and is it up-to-date?

(The crash report is #49798)

Thanks,
Marc


#3

Can I configure SketchUp to use Firefox or Chrome?

Internet Explorer 9 is installed on my computer. It doesn’t launch. It doesn’t show up in Start menu search. It doesn’t show up in Add/Remove Programs. I can’t delete it from Program Files because of a permissions glitch. I tried downloading and running the IE11 installer, but it won’t run because “there is a more recent version already installed.”

In university I was forced to rent this laptop. When I graduated, they sold it to me for 1$. There are several latent software problems, but this is the first time one of them has actually caused a problem.


#4

Here is a link for instructions on installing / uninstalling IE9. It’s not done through the normal add / remove programs, but through Windows Update.
http://windows.microsoft.com/en-us/windows7/how-do-i-install-or-uninstall-internet-explorer-9

SketchUp uses the system web browser (IE on Windows, Safari on Mac).


#5

Uninstallation through Installed Updates fails. Internet Explorer doesn’t work on my system at all, even if I copy and paste a known-good installation from a near-identical, up-to-date computer. I must have messed up my system at some point and I’ll have to do some more digging.

EDIT: Yup, my system is pretty messed up. No IE, limited updates running, rescue disc doesn’t boot, and factory reset partition doesn’t boot. Might as well close this thread.