SketchUp crashes immediately when opened, pl. help to resolve the issue

My sketchup crashes immidiately when opened, pl. help to resolve the issue

Please report back with details about your computer hardware. and OS / SketchUp versions… and don’t forget to add in the make and model of your graphics card.

Poor graphics support can be a common reason for crashes. But then so are outdated plugins.


Also, try to put a little context into place here. . .

Is this a recent and sudden occurrence?

Is it a new install of SU that has never managed to run?. . . OR, is there a track record of past success with running this version of SketchUp on your computer system?

1 Window 8 ; 64 bit desktop2 Sketchup2015 Make has been running normally from last one year without a single crash until yesterday when the sketchup suddenly crashed. Since than I am unable to open it. 3 The sketchup file opens and suddenly gets crashed.4 On opening a sketchup file it prompts these two messagesBG Sketchup Library not installed &. You must instal LibFredo6 ver6.3 to run Fredo 6 tools
But the file used to open with these messages ,never had any problemThe problem started after installation of a softwareWindow 10Upgrade Assistance
RegardsFarakh Aslam

You still have not reported what your graphics card is as per Jim’s request. Please do that and update your profile with it.

Your sudden crashes are most likely related to the graphics card drivers. As a guess, I wonder if you have an AMD/Radeon card. If you do, you probably have an application now called Plays.TV which was installed automatically Radeon GPU driver updates recently. Look for that application and uninstall it. That has been shown to fix the immediate crashes of SketchUp.

As for the other messages you get related to extensions, if you are still getting them after fixing the crash problem, update the indicated files.

DaveI only graphics card I could see is Intel@HD Graphics Driver which came when the system was bought in 2012, There is no such AMD/Radeon card in my system. please advise
Farakh

Try disabling Hardware Acceleration under Window>Preferences>OpenGL. Then quit and restart SketchUp. See if that helps.

Intel HD graphics drivers have been problematic for poor OpenGL support. You might search here for other threads related to Intel HD graphics.

Any newly installed extensions or other changes made to SU?

Go to Control Panel
Go to Programs and Features
Check “View Installed Updates”
Find and Uninstall this problem Update.

Hope a restore point was made before the update.
Go to start, control panel, system, Then in the left top corner select system protection, then pop up window will show a restore. If it now works ok try the updates again. The file prorection is not perfect and a error may have occurred and the Windows did not catch it.