Sketchup crashes as soon as main window loads

Hi all, I’m getting some crashing issues when trying to use Sketchup.

I had this a while ago, and fully reinstalling worked. Until the program needed to be run again and it didn’t work, so I gave up. I’ve reported this bug a few times (It’s happened 14 times according to the BugSplat thing) but I would like a solution as I haven’t managed to find one.

According to the BugSplat log, the most recent ID is 269504, if it helps anybody.


The common cause for this has to do with an application that was automatically installed with a recent GPU driver update for Radeon cards. It’s called ‘’ Look for it and uninstall it if it’s there. See if the Bug Splats on startup quit.

There are many threads on this already.

I do not have that application.

I’ve managed to get it to run by setting the Graphics Acceleration values in the registry /Prefererences key to 0. However, the prefreences dialog now doesn’t work.

Hardware Acceleration off was going to be my next suggestion. Radeon cards are well known to have poor support for OpenGL so turning off Hardware Acceleration is usually helpful.

Another thing that seems to help is uninstalling 64-bit SketchUp and installing 32-bit instead. Radeon cards and Windows 10 drivers seem to have trouble with 64-bit applications.

Are you saying you now can’t open the SketchUp Preferences window?

Where did you disable graphics acceleration? From inside SU at Window > Preferences > OpenGL and disable Use hardware acceleration?

I couldn’t open the application to change the preferences, so I had to go into regedit and go to HKCU/Software/Sketchup/Sketchup2016/Preferences (Do so at your own risk)

It runs like ■■■■ but at least it works kinda.

And yes Dave if I open go Window > Preferences I get an instant crash

Did you try the SU 32-bit version?

Do you have any SU plugins installed?

I’m going to try the 32 bit in a few minutes

Lee; Have you followed the other trouble shooting steps Trimble has in the help files; The Bug splat is probably on your machine it may help to make it available here for others to look at ; have you tried to roll back to a restore point when PC was working; Hope MS lets you do that for W10:confused:

There is more than one registry attribute that needs to be changed. You have likely gotten them “out of whack.”

Use POSH, GmbH’s free utilities to change the registry settings whilst SketchUp is not running.

They are a German distributor for SketchUp. (@sketch3d_de, represents them here.)

Otherwise you can use the batch files I posed:

For SketchUp 2016:

[Win] Setting Preferences > OpenGL switches off via batch script - #6 by DanRathbun

For SketchUp 2015:

Thanks for the help there Dan, but after I uninstalled 64-bit and installed 32-bit, all of the preferences sorted themselves out (Which could be annoying if you wanted preferences to persist through installations, but not in this case) and everything works now.

Thanks for the help everyone, I haven’t noticed anything else screw up with 64-bit OpenGL so far, so I’ll keep it in mind for future.

Post mortem, it’s the Radeon driver for 64-bit OS on Win 10. For some reason, the driver provides more complete OpenGL functions calls for 32-bit programs.

Can confirm, bugsplat #269504 is a crash in the graphics driver atig6txx