SketchUp bugsplat on startup

I haven’t opened SketchUp for months. Now it doesn’t open and bugsplat keeps appearing everytime I tried launching. Prior to this, my SketchUp 2019 Pro was working just fine. I already updated my graphics card driver, but still it didn’t work. I tried installing SketchUp 2020 Pro but the same thing happened, it always end up with a bugsplat. Does anyone have any idea how to fix this? :frowning: By the way, I have Windows 10 home single Language and Intel® HD Graphics 520 and AMD Radeon™ R5 M330.

Commonly Bug Splats on startup are caused by a problem with the graphics drivers. Your profile indicates a couple of different graphics cards. Make sure their drivers are up to date. Don’t ask Windows to tell you that, though. A Windows update probably installed a bad driver update. Go to the graphics card manufacturer sites and get their latest drivers to install.

Also make sure you installed SketchUp correctly. That is, you right click on the download installer file and choose Run as administrator. If you didn’t do that before, do that after updating the graphics drivers and if you are prompted, choose Repair.

1 Like