SketchUp bug splat every time

My skp pro, wich I just downloaded, crash every time, I even cleand my laptop and it continues this way, it crashes even with nothing created in the scene, just some minutes after, I tried with skp 2015 and 2016 nad its the same.
Its a laptop dell core i7 16GB RAM

A couple of questions:

  • List item Did you include your name or email address in the BugSplat report?
  • Which graphics card does your Dell laptop have?

Mark Chandler

I havent send a report, sometimes it just close the program without a bug splat message.
My graphic card is an AMD Radeon R7 M270

Have you tried updating your graphics card’s driver?

Hi I downloaded it with the 32 bit versión and it seems to be working fine, but… is the same working funcionality as 64 bit? sorry, I am not an expert in this topics

No difference in functionality between the 32- and 64-bit versions.

With the latest drivers, a laptop with an AMD Radeon R7 M340 I have been testing lately has worked quite OK with SketchUp. About a week ago, our work tech support installed some Windows 7 updates after which, typically, the machine started bluescreening when idle, but updating the Radeon driver seems to have fixed that.


Ok, I upladed my graphic card and then re install 64 bit and again bug splat so I will use 32 version since it worked fine

Is your SketchUp set to use the Radeon card instead of integrated graphics? You can check in the Radeon control panel application settings.


I am having the same problem… im using an XPS 15" 2016 with nvidia graphics card 1050 its the i7 model.

I bought this machine to crush sketchup. Pretty disappointing.

It is pretty disappointing when your computer doesn’t live up to your expectations. Perhaps there’s something you can do, though.

First, did you install SketchUp correctly using Run as administrator after right clicking on the installer? To be sure it is installed correctly, find the installer file and reinstall using Run as administrator followed by Repair. Use your normal login method to Windows.

Second, check to see that your graphics drivers are up to date. Update them if there’s a newer version available.

Third, make sure that the nVidia card is set up to be used by SketchUp. A quick way to find out is to go to Window>Preferences>OpenGL and see what SketchUp reports as the graphics adaptor it is using. If it is using the Intel adaptor, change that to the Nvidia card in the Nvidia control panel.

Michael is using a laptop. Laptops default to its Intel graphics chipset. Specify using the NVidia for SU in the NVidia control panel’s 3D Settings. Depending on the OS, either r-click on an empty desktop space and chose the NVidia Control Panel or r-click on the SU desktop icon and pick the option to specify your graphics for SU. As each version of SU is a distinct installation, this would have to be done for each SU installation.