Sketchup Acting Insane After Update


It is now crashing over & over too:\

Try going to View and turning off Axes

See if this has anything to do with your problem:

It’s crashing too fast now. It barely even opens before crashing currently.

are you still working on a mac using mac os 10.15 catalina ?
if so it’s not supported by SU 2024, it’s big sur (11) minimum. 2023 was the last one supporting catalina.

and even if it launces, you’ll have to go to the preferences / graphics and pick the old classic engine, the new one is only compatible with mac os 12+

I’m using Monterey

Please correct your forum profile. ‘2023’ doesn’t identify the operating system and ‘Mac OS Catalina 10.15.7’ is not a graphics card. If you are using SketchUp 2024 please update that in your profile, too. The correct information in your forum profile helps us help you.

I honestly had not remembered I even had a forum profile. I think it’s updated now.

1 Like

Your decade old Mac has an unsupported GPU for the new graphics engine that is in 2024.

You can find this info in the official help documents/ system requirements.
SketchUp Hardware and Software Requirements | SketchUp Help

Switch to the classic graphics engine it in the SketchUp preferences.

or get a new computer :stuck_out_tongue_winking_eye:

Umm ouch, LOL! How would one ‘classic graphics engine it in the SketchUp preferences?’

You were dead on, switched to classic graphics engine. I just had a call w/tech support who assisted me in figuring this out. I had not done the math on the age of my computer lately so thanks for pointing that out, haha. I guess that’s my next splurge.