Sketchup 2024 less stable than 2022

I’ve recently upgraded to 2024, using the same plugins I was using on 2022 (almost exclusively Fredo6 and TomTom), and I have to say so far the experience has been frustrating.

It seems to freeze for extended periods, or crash entirely on a pretty regular basis, and I’m losing hours of productivity. Is anyone else experiencing this, or is it just me?

I have decent enough hardware, with 32GB RAM and an RTX 2080ti GPU.


Have you tried switching the graphics engine?

I can’t help you but I too am still on 2022 with an RTX2070, I gave 2023 a miss after using it for 10mins, I was hoping 2024 would be better but your post doesn’t give me any hope.

I’ll wait for a point release (2024.1) before I give it a try. There are too many bug reports here for things like multi-monitor support or graphic glitches for my liking.

I’m on the new one. I’ll try switching to the old one to see if that helps.

Also - did you install extension from the warehouse / sketchucation or by copying over?

Have you tried disabling all extensions and then seeing how it goes?

And, to add to the questions, have you tried updating your Nvidia driver from the Nvidia site?

1 Like

2024 is pretty solid for me. So far so good…
12th i9-12900k, 64 gb ram and RTX 3080 driver v 546.33 on Win11 Pro 22H2

Did update to SU Pro 24.0.553 this morning, 24.0.553.

@DanGovier have you tried 2024.0.1? It has a few fixes for issues with the new graphics engine:
Download All | SketchUp | SketchUp

1 Like

And more questions. Do you have SketchUp set to use the Nvidia card in the Nvidia control panel?
What is the size of the model, post here for critique.

Thanks for the responses everyone.

The extensions are all installed from the Sketchucation ExtensionStore itself (v4.4.1). I haven’t tried disabling them yet, because the crashes are entirely random and not happening when actively using a plugin feature.

For example, first it was throwing a BugSplat when copy-rotating a group containing two components, but only after I typed /2 following the copy. That was happening consistently, then seemingly stopped on its own.

Today I’ve had Sketchup just close twice, seemingly during its autosave. No BugSplat, it just closes. Frustrating, because the one feature designed to save me from losing work, is causing me to lose work.

I am running Sketchup 2024 version 24.0.484, on Windows 10 version 10.0.19045.

I’ll go ahead and update to Sketchup 24.0.553.

My GeForce driver is 546.01 (October 2023), but a new driver came out a week ago so I’ll update to that and see how it goes. Sketchup is definitely using my 2080ti.

My model is 84MB in size, with objects extending to about 150m away from the global origin point.

That may be the root cause. Evaluate after the driver and SU updates.

1 Like