Sketchup 2024 bugsplats

After using SKP 2024 for quite some time now, we experienced a lot of bugsplats and it frustrated us. We then figured something out:
For context, me and my partner have been using decade year old desktops:
32gb RAM with NVIDIA Geforce GTX 670,
and another desktop with 12GB RAM with NVIDIA Geforce GT 625.
So, we just had to:

  1. set “Multisample anti-aliasig” to “0x”
  2. uncheck “Use maximum texture size”
  3. and choose option of “Use classic graphics engine”
  • all of which makes our sketchup programs stable, and still performing well without sacrificing much graphics quality, despite having really old GPUs.
    Hope this helps to those who still encounter bugsplats!
    Godbless!
1 Like

Have you also checked for a new version of the Nvidia driver from the Nvidia website?

yes sir, we’ve already made sure that we have updated graphics cards drivers. It’s just that we have really old GPUs.

1 Like