SketchUp 2024 Bug, Styles Palette on Trays

Can you help me please?!
Since I upgraded to version 2024, I have had a recurring problem.

After trying everything for weeks:

  • Complete reinstallation of Windows 10 from scratch
  • Reinstalling SketchUp
  • No extensions installed

I think I identified the problem.
Everything works perfectly except when I display the “Styles” palette in a tray…

When I save my file, SketchUp does not respond, and takes up all my processor resources.
Can’t turn it off, even task manager won’t start.
Require me to force shutdown my machine by holding the Power button.

I don’t know what to do anymore… SketchUp is my main work tool and I need this Styles palette in my daily life. I lost a lot of business because of this.

Thank you in advance for your feedback

Sketchup 2024.0.554 wont fix the problem.
I have wasted a day since up grade the patch.
Crashes and stalls
Something is wrong with sketchup 2024

1 Like

do you have crashes with the style panel too ?

or are you going through every crash thread to mention your issues ?
your messages, though plentiful, are quite vague regarding the circumstances of the crashes and steps you already took.

1 Like

Thank you for your reply. I see that you are very active on the forum. Do you have a solution for me? Or should I go back to the 2023 version?

No crash with styles, I don’t bother with the details of the crashes, but now will. I just work through issues.
I changed graphics back and will wait and see if ok
Thanks for advice

1 Like

Sorry, can’t be very helpful on this one, haven’t seen this issue yet, and it doesn’t proc on win11 - at least on my pc.

it’s 4.40 am in colorado (sketchup HQ) right now, so help is sleeping, but I can ask a few more details so when someone comes around, they’ll have answers ? (@colin you might have a new bug)
it’s like going to the ER and listing to the nurse all you can think of before seeing a doc :wink:

can you confirm you’re all good on updates ? win10, your GPU (check the drivers on Nvidia’s website, don’t trust microsoft ^^)

There have been issues with multi screen machines if the zoom is different on different screen, say 100% on one and 150% on the other. Are you running SU on one or more screens ? if so could you give us details (resolution and zoom). does it freeze if you only keep one screen ?

The interface is independent from the new / old engine thing (as far as I know), but… do you crash with the new and or the old engine ? you can switch in the preference panel (switch and restart)
The interface was changed last year with a new framework, QT, was it working fine in 2023 ?

what’s annoying is that it doesn’t actually crash, so no crash report. a crash report would make it easier for the devs to look at what’s wrong.

honestly, if you plan on working today, 2023 it is.
You can have both installed at the same time, no need to get rid of the old yet, plus files are fully compatible, so it’s a good backup.

switching to a new framework after 23 years (last year) brought issues, not everything can be ported as it was.
Same goes for the engine this year, after 24 years of openGL, moving to DX12 and Metal is a big step that comes with challenges :confused:

1 Like

Thank you Nurse Ateliernab.

There is a styles related crashing problem that is to do with match photo scenes, and only was seen crashing in LayOut. Does your PC lock up if you open SketchUp and start a new Simple template document, and Styles happens to be showing? Also, like Jrusty1 is trying, does using the classic graphics engine make any difference.

If the lock up happens with specific documents, can we look at one of those?

Neither of you have sent in bugsplat reports, if you do see one appear please send it in.


Thank you @Jrusty1, @ateliernab et @colin for your quick responses.

I’ve done a few tests since.
I updated my graphics card driver (Nvidia quadro M1200), I set my 2 screens to 100% display and I tested with the new SketchUp graphics engine and the classic.

Results :

  • With the classic graphics engine it seems to work even on the 2nd screen.
  • With the new graphics engine, the problem persists even when disconnecting the 2nd screen and setting the main screen of my laptop (MSI Workstation) to 100% and with a standard model (mm architecture)

The problem is not caused by the match photo, I carried out these tests with simple cubes.

My configuration:
Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz 2.80 GHz
16.0 GB (15.9 GB usable)
64-bit operating system, x64 processor
Windows 10 Professional

I will continue testing with the classic engine on a large project from scratch and I will keep you informed if the problem persists on this configuration as well.

However, I would like to succeed in solving this problem with the new graphics engine, if you have other suggestions, I am interested.

Unable to get a “bug splat” window to report to you. This happens on several file types, not one in particular.