SketchUp 2023 - Layout crash on start

I’m having issues with Layout, when I try to open any Layout file or the Layout app directly it crashs and give me an bug error message.

I have updated SketchUp to latest 2023 version (23.1.340), nVidea driver (RTX for Laptop 546.33) and .Net (7.0.15), and still no success.

Do you mean it gives you a Bug Splat or are you getting some other message? If a Bug Splat are you sending the report in with your e-mail and name attached so the report can be identified? If some other message, what is it exactly?

Did you install SketchUp correctly by right clicking on the installer and selecting Run as administrator?

By the way, you put SketchUp for Schools in your forum profile. That is a web-based version for school children and it does not include LayOut. Please correct your forum profile.

Hi DaveR

It gives me the Bug Splat message. Yes, I’m sending it identified.

Yes, installed using “Run as Administrator”. Only Layout is not working, SketchUp is running fine.

Ok, I’m going to update the profile.

Best regards,

Maria Darck

OK. Well, that’s good. Maybe @colin can look up your Bug Splat reports when he gets in to work and give you an idea of what might be the cause.

Has it worked before or have you only recently installed SketchUp 2023?

Please do. That information helps us help you but only if it is correct. Thank you.

I opened the XML file generated by Bug Splat and it just have a tag on it with “.NET”, this is why I choosed to update the .NET version on my PC.

It was working fine, when I tried to open a project yesterday I received the bug screen.

That may or may not have anything to do with it.

So what changed on your computer between when it was working and when it stopped. SketchUp 2023 hasn’t had a recent change so it must be something else.

You could try repairing the installation making sure you right click on installer and choose Run as administrator followed by the Repair option. Might help, won’t hurt, and it’ll give you something to do while you wait for Colin.


Nothing, I have not installed any new software or made any Windows Update.

I have already done that and did not worked. Then I tried the following procedure:

Install directly with the new version

Even doing this, is not working.

Another, slightly more invasive thing to try while waiting for Colin:

Go to your user AppData folder (it’s normally a hidden directory) and go to the folder shown below. Delete the .plo file. Then try starting LayOut.
Screenshot - 1_15_2024 , 9_13_19 AM

I done the recommed step, but even doing this i was not able to open Layout:

Sent new bug files generated after removing the PLO files too.

Well, go do something else for a while and give Colin a chance to catch up from the weekend. I’m sure he’ll check in on the forum.

Just remembered it’s MLK day. He might have the day off although probably not.

I do have today off, but that didn’t stop me from looking at bugsplats…

Bugsplats are not easy things to read, and I can’t tell from the three that Maria sent in what the issue might be.

@trent is most likely more serious about his days off than I am, but when he is working he could ask the developers to take a look at the reports.


Next thing to try would be renaming the layout folder to LayOut_old, then try to start the App.

Tried that too and still the same problem. Sent new Bug splat report with comments to identify the new try after rename the original Layout folder from APPDATA.

Thanks for your help!

Does StyleBuilder start?

Yes, StyleBuilder it’s working and SketchUp too. Only Layout it’s not working.

I compared your first bugsplat and the one you just sent in. The crash is the same.

Thanks all, I will see if we can get some eyes on this.

Hi @maria.darck,

It looks like one of your recovered files may have somehow become corrupted. can you try renaming your working directory to working_old? That is located at <username>/AppData/Local/SketchUp/SketchUp 2023/LayOut/working (note Local vs Roaming for this location).


1 Like

Hi @adam! Thanks for your help. After renaming the working to working_old the Layout opens, and closes before it finishes to load. Now it’s not generating the bug splat any more, but still not working.

Is this still the case? We haven’t received any crashes from you since then. Does LayOut completely go away, or can you do a File->Open? Even a new, blank file won’t open?