SketchUp 2022 constantly not responding on MacOS

I use SketchUp and Layout professionally to model furniture and make shop drawings for our fabrication team at a small furniture manufacturer. For several months across multiple MacBooks and macOS versions SketchUp 2022 has been constantly “not responding” while trying to work on models. At random times I will get the spinning color wheel and will need to Force Quit SketchUp and reopen it to continue working. Sometimes when I reopen SketchUp it will immediately open the file I was working on, sometimes I will get a warning saying I forced SketchUp to quit with the option to send a report to Apple. Very rarely will I ever get a BugSplat screen upon reopening if at all.

Additionally, a recent issue I have run into on the new laptop is when I go to close SketchUp, the OS will give me a warning saying SketchUp quit unexpectedly. When this happens I do get a Bug Splat and I have filled out a report for SketchUp support. (This problem is less of an issue than the one mentioned above).

I have tried just about everything I can find on the forums. I have tried:

Reinstalling SketchUp 2022
Restarting my computer
Updating my OS system
Running SketchUp through Rosetta
Deleting all plugins
Keeping the components window closed
Rebuilding all components in our library so geometry is not tagged (only groups/components)
Rebuilding our SKP template from scratch
Rebuilding our materials library using images <200KB
Working on files locally instead of through Google Drive File Stream
Turning off iCloud syncing
Only using SketchUp with no other apps running
Purging SKP files
Running SketchUp through Terminal to see if anything was happening in the background
Using First Aid in the Disk Utility app
Turning off “Automatically fix problems when they are found”
Turning off “Use fast feedback” under OpenGL
Modeling without textures
Using the ThomThom CleanUp plugin
Removing detail from my models to simplify geometry
Turning off auto-save

I have seen suggestions of deleting the .plist preferences file but I cannot find this file so I have not been able to try this.

This has happened for months now on my old laptop and my new laptop. My boss has gone as far as getting me this new laptop as we thought it was a memory issue because the last laptop only had 8GB of memory (MacBook Pro, macOS Catalina 10.15.7, 1.4GHz Quad Core i5, Intel Iris Plus Graphics 645 1536MB). It has actually been worse on the new laptop with 32GB of memory–crashing upwards of a dozen times a day.

The files I work in range in complexity–the current one I am working in is 9.2MB with ~97,000 edges, ~34,000 faces and 352 component instances. However it will even “not respond” with less complex files containing much less geometry. With the specs of my current computer I would expect it to be able to keep up with more complex files, so I don’t think geometry count issue or even an issue with a single specific file.

I am really at a loss with what else I can try. It is to the point where it is almost unusable and we may need to switch to an alternative program like Fusion 360. I want to avoid switching programs as we have a very optimized workflow using SketchUp and Layout. Any help is appreciated.

Thanks,
Braden

Are your figures with the “Show nested components” box ticked? The edge count sounds small for the file size and componentization level.

Hey there, It is with the “show nested components” box ticked. If I uncheck it, the count goes down to 0 edges, 0 faces and 6 component instances.

We use a lot of metal stock at our shop so a lot of the components are just 6 sided rectangular prisms to represent lengths of square tubing, rectangular tubing, or flat bar.

I don’t use a Mac but based on what people have written on the forum people have very variable results running SketchUp on the latest, yet unsupported, version of MacOS.

I considered that possibility, but it seems to be the same issue on both computers that are running different versions of macOS. Appreciate you trying to help out though. It seems like I might just have to wait until SketchUp 2023 is released to see if that improves things.

Are both computers Apple silicon (m1 or m2)? That could affect the behavior. I haven’t seen it when running Ventura on my Intel-based Mac.

I think the complaints and success reports are coming from both Apple Silicon and Intel Mac owners. Did you install SketchUp before or after upgrading the OS?

Before, I think…

It should be at

~/Library/Preferences/com.sketchup.SketchUp.2022.plist

That file deals mainly with position and size of various windows, toolbars, inspector panels, etc. Since a few versions ago, most user settings are kept in

~/Library/Application Support/SketchUp 2022/SketchUp/PrivatePreferences.json
and
~/Library/Application Support/SketchUp 2022/SketchUp/SharedPreferences.json

Note that your user Library folder is normally hidden by Finder. “~” is traditional shorthand for “/Users/xxxxx/Library” (where xxxxx is your user id). You can get there via the Finder’s Go->Go To Folder menu item if you copy and paste the path exactly as given above (spaces and capitalization matter!).

Would you recommend deleting all 3 of those files?

I believe that if you delete them SketchUp will regenerate them the next time it runs. But be aware that all your settings and preferences will revert to default.

You could rename the files, and if that doesn’t help you could delete the new ones that are created, and rename the old ones back to the normal name.

I renamed those 3 files so that SketchUp would generate new files, however I’m still experiencing the “not responding” issue. I’ve tried and tested some different things to see if I could figure out if there is a pattern to the issue, but can’t seem to come up with anything.

Hi all,

My studio is currently using MacOS Monterey but Trorg says this might well work on any. Please try if you have Ventura, our studio would like to know if the upgraded OS will work for SketchUp (it why we bought the M1 Max Apple Studio).

Here is a solution from my friend Trorg Mjolnir, he’s a Apple programmer from way back. He seems to think it will also fix any 2021 issues.

Our studio just bought a Apple Mac Studio with an M1 Max chip and installed SketchUp 2022. Sure enough, it did not open a window, and force quit was the only thing to do. So here is a solution if you please…

Remember your Mac is just a fancy UNIX box! (says Trorg!?!)

On the desktop make a file with this single line in it, nothing else.

/Applications/SketchUp\ 2022/SketchUp.app/Contents/MacOS/SketchUp &

Two things here…

  1. The & symbol at the end puts sketch up into the background like you want it (probably).
  2. Now, make the file executable (if you know how). Clicking on it will then open SketchUp as it will when they fix the problem (if this isn’t it).

One more thing:
I understand UNIX and the terminal can be intimidating, so, if you want the above done for you, open a terminal window (/Applications/Utilities/Terminal.app) and just copy and paste the following in. You can even just highlight the line below and drag it into a terminal window, then hit the return key on the keyboard. Find the new ‘sketchup’ on the Desktop and double click it. Good luck and I hope you are off and running with SketchUp. Our studio loves it.

echo /Applications/SketchUp\\\ 2022/SketchUp.app/Contents/MacOS/SketchUp\ \& > $HOME/Desktop/sketchup; chmod 700 $HOME/Desktop/sketchup;

Thanks! I’ll give this a whirl and let you know if it works.

Yeah, that didn’t work. It also looks like this is a fix for a different issue that was present in macOS Monterey, not Ventura.