Sketchup 2021 takes forever to open legacy files

I just updated from Sketchup 2017 classic license to Sketchup Pro 2021. I’m having great difficulties opening my files which are made in Sketchup 2017. It takes forever. While opening the program is unresponsive and eat’s up a lot of CPU and RAM but doesn’t crash and it literally takes like 20-25 minutes. Meanwhile I just see the spinning wheel. The same file opens in just seconds in Sketchup 2017.

Any ideas what might cause this issue?

can you share an offending file?

I have a feeling it’s due to lighting from the extension “twilight render”. That’s the render I use. I used it with SU 2017 and I’ve also installed it on my 2021.

It took 25 seconds to open your file on my computer using SU2021. After I purged the unused stuff from the file…
Screenshot - 11_20_2020 , 6_49_00 AM
…it opened in about 6 seconds.

That also reduced the file size by about 92%.

I saved the file using the Monochrome face style and it opened in 3 seconds.

You should get in the habit of correcting face orientation. Exposed back faces could give you problems when rendering.

Make sure you are using tags correctly. ALL edges and faces should be untagged.
Screenshot - 11_20_2020 , 6_57_30 AM

And clean up your models as you go.

1 Like

A little further cleanup with CleanUp3 reduced the file size a bit more.
Screenshot - 11_20_2020 , 7_09_14 AM

Now it’s down to 7% of the size of the file you shared.

I just curious and thinking a loud…

While are totally agree what Dave did it’s a way how to do!

But this one does not explain why:

? :thinking:
(PS.: Now I’m behind a corporate firewall, I can’t download the file. I’ll do from home…)

A guess would be that it might have something to do with the file format changes made in SketchUp Pro 2021.

Of course, can’t know for sure.

Quick study:

  1. I just opened the original file (130MB) with
    SU2017Make: ~ 10 sec
    SU2020: ~ 10 sec asked if I want to fix problem then after other ~25 sec is opened
    SU2021: ~ 30 sec (I guess this one fixed it without question)

  2. I saved the fixed file with SU2020 as 2017 format. Then opened:
    SU2017Make: ~ 9 sec
    SU2020: ~ 13 sec
    SU2021: ~ 13 sec

  3. I purged then I saved the file with SU2020 as 2017 format. (20MB) Then opened:
    SU2017Make: ~ 5sec
    SU2020: ~ 5 sec
    SU2021: ~ 5 sec

  4. I saved the purged file in SU2021 and ended up with 10,6MB and opening time ~ 3 sec.

Lesson learned: :innocent:
a) There was an error in the original file what SU2017 did not recognize, therefore opened it without fixing .

b) A later version of SU has already been prepared to detect this kind of error, so the time spent correcting the error increased the opening time.

c) The SU2021 format is really using less space! :+1:t4:

As @Teeem pointed out, that first opening in 2021 probably includes some file adjustments for the new format, too.

Clearly, though, the model needs tidying up, though.

I ended up with 9.18 mb. :wink:

1 Like

After CleanUP 9.14MB (9 686 547 bytes)
I won! :stuck_out_tongue_winking_eye: :beers:

1 Like

:laughing: :beer: :beers:

1 Like

There was another improvement in 2021 that didn’t get called out in the release notes, and you can test this to see how much difference it makes:

Open a large 2017 file in 2020, note how long it takes for the “this is an old format” dialog to appear. Now click Ok, and see how long it is until you can model. The two times are often the same.

Try the same test in 2021. The time from clicking Ok is a lot shorter.

1 Like

Thanks for all the replies. You guys obviously know a lot more than I do about this. Is there a way to clean up the file without opening it in 2021 since it takes so long for me to do so?

Everything I did could be done in SketchUp 2017. The extensions I used all work in that version and 2018, 2019, 2020…

Here is a 2021 version of your file:

It now opens quickly. The report that shows what SketchUp had to fix is 2,088,396 lines long. Yes, it had over 2 million problems.

1 Like

Ok so I installed CleanUp3 on my SU 2017 and tried it out on the model I shared with you. I got it down to 16 mb. and the load time is now only 4 seconds. Thanks you SO MUCH guys.

However I feel like I’m flying a bit blind – I don’t really know which of the options in ClenUp I should use and which not to use. I tried running it with the default setting but cranked the “Smooth edges by angle” up to 10. Seemed like it worked well and nothing of importance has been removed/altered in a bad way. Maybe that’s just luck however.

What’s your thoughts on which options to use?