Sketchup 2021 Layout is unworkable slow

Hi,

I am an average user running Sketchup Professional 2021. I am using a desktop pc with the following specs:

Processor: AMD Ryzen 5 5600X
Motherboard: ASRock X570 Phantom Gaming 4S
Graphics card: ASUS ROG Strix Radeon RX5700 XT O8G Gaming (1,81-2,035GHz, 8GB GDDR6)
Memory: 2x Transcend JetRam JM3200HLE-32G (64GB)
PSU: Cooler Master MWE Gold 650 - V2 - Full Modular
Storage: Samsung 980 Pro 500GB

I am running Windows 10 x64 20H2 with the latest updates. I am using the latest drivers from the AMD website. I have enabled Sketchup as a gaming program in the AMD Radeon settings and I’ve changed the config to performance settings.

I am working with files that are approx 300MB, filled with custom design and also warehouse items.

My issue is as follows.

When I am working with designs in LayOut, LayOut is responding very slow to most actions. For example, when I try to set a few measuring lines, the setting of the measuring line within the design is very haltering.

This results therein, that Sketchup (especially LayOut) becomes (almost) unworkable slow.

Also, when I open my designs in LayOut, it takes about 30 seconds to open them. I also get the “Not responding” error in Windows when I click the window when it’s loading.

When I perform these actions on a PC of only of my colleagues, the same design, but a different (less performing) videocard Nvidia GTX 1050 Ti, less performing CPU, and less memory, LayOut is also not very rapid, but it is workable, it is about 10x faster than it runs on my pc.

Does anyone have any idea what might be the cause of this issue, or any tips what I can try to improve the performance?

If I need to provide more information please let me know, and I am more than willing to provide. I have searched a lot on the internet but I can’t find any possible cause.

Kind regards
Patrick

We need more information Patrick.

Do you have a Layout file you could share that is causing your slowness?

How many pages in the Layout file, how many viewports, are you making use of turning off the tag(s) of high poly items that are not visible in some viewports, etc…?

What monitors ( pixels )?
What scaling are they set?
It’s all about pixels.

@paul.mcelenan: I’m sorry but I can’t share the file itself, because the customer wouldn’t want this for privacy reasons etc. But maybe it helps if I explain a bit more. It is a Sketchup file of one complete house floor (only walls and everything inside) with all details, like a kitchen with built-in electronics, a table, chairs, a sofa, television, built-in design cupboards, a Bathroom, living room, plants, etc. etc. We have 13 scenes and the export is done 1:1 to LayOut.

How many pages in the Layout file
→ 4 pages

how many viewports configured →
We have 13 scenes in the Sketchup file

are you making use of turning off the tag(s) of high poly items that are not visible in some viewports, etc…?
→ No this is not what we are doing. In Sketchup we want to have all details visible to show to the customer, to give a ‘home feeling’. Maybe we could turn off some stuff before creating the LayOut file? Would this make a difference?

What monitors ( pixels )?
What scaling are they set?
It’s all about pixels.
→ Two quad HD monitors, so Sketchup is opened in one monitor 2560x1440
The font scaling in Windows was set to 125% and indeed it makes a huge difference if I put this back to 100%. Now it is still a bit slow, but it has become way more workable. Thanks a lot for your tip.

Could it possibly (also) be the hardware? To me this is quite heavy hardware for a program like Sketchup and Layout. I thought it would run these programs very easy and smooth. If I look at Windows task manager processor/RAM/GPU load, this feeling is confirmed; all numbers are below 20% even when performing actions within Sketchup or Layout. So question is still, why it’s not more fluent: I have more power left within the desktop, but Sketchup or LayOut seem not to be using it at all.

PS: all drivers are correctly installed from the original manufacturer’s websites and ‘Device manager’ is not showing any unrecognized device.

1 Like

There’s your problem. All the useless detail, probably all the internals of the stove have highly detailed screws. Etc etc

Just to be clear, what I mean is that, say, in a specific viewport in Layout that, say, is showing the kitchen, the viewport in question will also be rendering detail in other rooms that are not visible in the viewport.

If every viewport in your Layout file is rendering the entire model when it doesn’t have to then that has a performance impact on Layout… that’s how I see it.

That’s where tag control is useful.

I understand, I need to dig more into tagging, how to do this efficient, and experiment with the differences in performance. I will try to do so the next coming days.

Besides this, it still feels strange that Sketchup, by itself, takes so few resources from my computer. If it would take more, it would be faster, even in the inefficient way I seem to be working right now (not tagging etc.).

Could it, possibly, also be my hardware? The Ryzen 5600X is quite a fast processor but it is not the fastest in the market. What are your experiences with your own hardware if I may ask?
And I’ve also read few things about the AMD RX5700 chip, that AMD might be less efficient in 3D/rendering than Nvidia is. Could it be that, for example, a Nvidia alternative to the RX5700 will perform way better than the RX5700 is doing? Maybe because Nvidia might be more efficient with programs like Sketchup?

No. Your problem is not one that can be helped with throwing more computer hardware at it. It is all the faces and edges in your model. You must note that the navigation speed, with all that geometry, is more dependent on the one CPU thread that SketchUp uses, and the graphics card, that calculates textures and shadows, sits mostly idle waiting for the CPU to supply it with work. This is the same with all 3D modelling applications.

Certain forum threads, however, have recently made me wonder if, contrary to what CPU benchmarks say, Intel still retains its traditional edge in the mathematics required to process 3D vector geometry.

How many times have you inserted the SketchUp file into the LayOut project?

As others have said, a large part of your problem is likely due to excessive detailing. I’d be willing to bet my lunch money that your kitchen appliances and bathroom fixtures are overly detailed. It’s extremely common especially with components from the 3D Warehouse.

FWIW, this one isn’t as obese as they come but there was still excessive geometry and such. I removed a lot of the unneeded stuff and converted some of the repeated elements from groups to components. This reduce the file size by 34%. It wouldn’t take much more to get rid of another 5 or 10%. If that’s done throughout a house model, that can be a big reduction and give you an improvement in performance.