2020 Setup, Slow, "Not Responding" Crashing "30+ seconds of nothing"

So have just downloaded the New Sketchup 2020 to my C drive which has a lot of free space, I have had ongoing issues with program “Not responding” both in SketchUp & Layout, either with saving file or opening the program, also happens when copying and pasting within the model which is quite frustrating. as it will stop working for at least 30 seconds… yes i timed it each time.

I have made sure the program is running though my GeFroce RTX 2080 Graphic card.
I have removed the program and reinstalled it but still the same ongoing issues…
My Layout and Sketch-up model are both in the same file also for reference…
but i feel like this program has some BIG bugs
has any one had this happen of have a solution to make the program run “quicker & smoothly”.
as iv had enough of closing the program down and opening it again just to fix it…

kind regards
Adrian P

When you installed SketchUp did you right click on the downloaded installer and choose Run as administrator?

Great question no idea… does it make a differences,

Yes. It does make a difference. Make sure both LayOut and SketchUp are closed. Find the downloaded installer, right click on it and choose Run as administrator. Then when presented with the option, choose Repair. After it completes do a power off reboot and then see how it goes.

Hey Dave,
Still doing the same thing honestly its just a really slow program even opening documents takes for ever.
kinda over it… no idea what iv done wrong but the program just does not like me… lol
My Autocad files open and operate way better this this program and their is alot more details layers and information in them…

I’ve been using SketchUp 2020 since it was released and haven’t see any issues with it being slow. In fact the performance has been better than 2019 on my computers. I use SketchUp on three different computers of different ages and with different hardware.

What happens if you change the state of Use Fast Feedback in Preferences>OpenGL?