Sketchup 2021 failed to open document error


A few days ago I made changes to an existing file, gave it a new name, saved it, all as normal. When I tried to open it today I receive the error message ‘Failed to Open Document’. I’m running SketchUp 2021 with latest V-ray.

Tried to find a solution but nothing current and I didn’t have time to muck around looking for more, so spent the last 4 hours making the same changes. Deleted unused components, ran a clean up (both SketchUp Purge function and CleanUp3. Saved it (again with a different name, and have a back up) etc. All seemed fine and was time to render… but… The Vray asset editor would open so I restarted SketchUp.

And it happened again! This is insane. I’ve done the following:

    1. Renamed the files - still same error
    1. Moved the files to another drive and renamed them - still same error
    1. Tried opening the SKB file - still same error
    1. Tried importing both SKP and SKB files into a new file. This causes a bug splat crash
    1. This has happened on two files and I’m too scared to work on any others. Both were 2020 and saved as 2021 with changes. Now the 2021 files won’t open

Do you know what could cause this corruption? Please help. I can’t face making these changes again only to have the same error message.


tive o mesmo problema, perdi o arquivo do cliente e o meu! E a equipe não resolve e nem mostra como evitar, LAMENTAVEL!