Sketchup 2021| Bugsplat / recovered file issue


I downloaded the new 2021 and was working in my model. The model kept crashing and I was receiving the bugsplat message more then normal. It is a fairly small file nothing crazy. The last bugsplat message I received it would not allow me to reopen my file, typically it would allow me to open as a recovered file so I was able to work from where I last left off. I decided to restart my computer. After restarting my computer the 2021 version has disappeared from my applications and older versions are only there for me to open. Has this happened to anyone else?

Do you mean that the 2021 Sketchup application is gone as in totally uninstalled? or that you were saving your files in the applications folder and the file is gone?

If the whole application is gone did you install it correctly by dragging the SketchUp folder into the applications folder as prompted by the installer? perhaps you were running off the disk image the whole time?

It uninstalled itself, so I have to reinstall it now. It also wont let me sign into my 2020 version because its stating that I am signed in somewhere else.

This makes me wonder if you hadn’t actually installed SketchUp 2021 but instead you were running it directly from the dmg.

Sounds like you had just double clicked on the sketchup icon in the installer. This runs the program from a temporarily mounted disk image. When the installer starts up there is a sketchup folder and an applications folder inside a window. You need to drag the sketchup folder into the applications folder and let it go.

I did that and it still doesn’t work. I drag the folder into my application folder and it still doesn’t want to open. These are the images I’m getting.

Not that it is relevant to your issue and I have nothing to offer on the Mac front, but it looks like you may have misspelled your email address.

I have some questions based on what I see in your screenshots.

In the first image, the dialog says "Copying 2 items to “Applications”. That should say either 3 or 4 depending on whether you did a previous install attempt, not 2. Which leads me to wonder if you are installing correctly. In the installer dialog, did you drag the SketchUp 2021 icon onto the Applications icon in the installer dialog. You should not drag it out of the dialog and onto the Applications folder in Finder. Also, you should not double click the icon in the installer to launch SketchUp.

Have you tried restarting your computer then redoing the install? It could be that there is some flag from a prior failure that needs to be cleared.

Edit: please update your forum profile. It says you are using SU 2018 on Windows, but the screenshots are plainly Mac and show a prior installation of SU 2020.

When I first purchased sketchup it was on my windows laptop but after two years I figured I installed it on my Mac to see how better works. To tell you the truth Mac is not that user friendly because there is too many function buttons to do one thing, But anyway I have installed it twice, drag the sketchup folder into my applications folder which it succeeded and I did restart my laptop before I had sent a reply but thanks all if I have any other issues I will be commenting or ranting.

now I have a problem with the toggle button in the tag box

I just bought a Perpetual License on Nov 4th-2020. All has been working fine. Use to have SketchUp-2017.

Today I downloaded and Installed SU-2021. All sign in boxes, fine. HOWEVER when I try to launch - SU2021.0 Bugsplats. Have turned my MacBook Pro off, Restarted, again same thing. Went back to open SU2020, all is fine.

Mojave, MacBook Pro.

Thanks in advance for any help.

Good day
Ron O.

Problem with the visibility toggle in tags?

@endlessfix the answer is yes. Right now I am trying to copy tags and list it under a new folder but it is not toggling on and off.

Can you share the file that is not working? I’m sure we can figure it out.


That’s impressive if you did that while following Aaron.

You don’t copy tags. What Aaron did, quickly, was to make a new folder, then make many new tags, and he typed in the names. To get the content across he copied from the ‘a’ tag, did an Edit/Paste in Place, then he changed the Tag in Entity Info, to move the duplicate part into the new tag that he had created.

He did say in the broadcast that it would be nice to be able to duplicate tags, but that doesn’t exist yet.

As for your crashes, the misspelling in your email made it very easy to find your four reports, though you would be surprised how many other people send in from ‘’!

The first crash was unusual, and the other three are something we’re looking into already. You could go into Utilities, run Disk Utility, select your drives (one at a time), and click the First Aid button, in case there is something that the system needs to fix.

@Colin thank you very much. I guess I was trying it a different way but it didn’t work and ended doing it Aaron’s way but one of the folders wouldn’t toggle. Thanks so much once again.

@Colin where do you see my email saying I’ve never even heard of this. I’m in the states.

Look at your last screen shot in message 5.

ooops I see. I haven’t misspelled in my other bugsplats. sorry didn’t realized that.