SketchUp 2019 is...not so great ;(

Having recently migrated to SketchUp Pro2019 I’m finding the whole experience pretty lack lustre… I work as a Set Designer in the film and tv industry and we generally work at a high level of turnaround (and expectation!). i’m finding the whole cloud based experience to be incredibly frustrating; lagging commands, unresponsive keyboard shortcuts, blue spinning wheels of Windows to name a few.
The modeling constantly does not perform in the way that I’m used to - trimming lines causes the model to lose faces and every time I slice through a 3d volume I am left with multiple faces lying on top of one another - sooo frustrating…

I have just purchased a brand new Windows machine, i9 processor, Geforce GTX 1080 8Gb, 16Gb DDR4 3200mhz ram, running off an ssd drive, so there is no chance it is a hardware issue here…

C’mon Trimble, what’s the solution? Do I have to go back to running SketchUp 2017 then?

Or head over to the Autodesk counter…

Not happy, Bob. Not happy.

1 Like

What version are you using? 2019 isn’t any more cloud based than 2018 or 2017 (with the possible exception of the licensing).

2019 - then I can’t blame the cloud for the lagging performance, then?

Am using subscription based License…

Make sure SU is using the Nvidia card and that the card drivers are up to date.

1 Like

And V-Ray is installed but I’m not using any extensions as yet.
Running 4.6.0 Nvidia 391.01 - GTX 1070 is running - not 1080 as stated :wink:

Agreed. web based version is slow, materials control is really limited. We are on genuine 100mb fibre connection and new 27" iMacs, no excuse for slow modelling. Lack of material control is not an option. for us, we architects and need accuracy.

We’ll be looking around for an alternative package - any suggestions?

Why on earth do people think that Pro is in any way web based. The subscription license is a web handshake, nothing more. If you have a classic license it doesn’t even need the handshake.

3 Likes

https://www.sketchup.com/products/pro-classic
image

If the web version of SketchUp does not perform for you, you should give the SketchUp Pro client version a try. You can even trial it for 30 days.

If you are currently running SketchUp Shop and you would rather move to the Pro subscription, there is a pro-rated upgrade path you can follow from your Account Management page. - https://ecom-prd.trimblepaas.com/ecom/portal#/subscription

CD

Agree!

Summary

Yea… because the “workflow” is: click>>click>>click>>click>>…
Instead of: think>>click>>read>>scroll>>read>>think>>click>>… :blush:

BTW. Nowadays trend:
…if there is no “cloud” or “bio” in the sentence, nobody will care…:stuck_out_tongue_winking_eye:

If I look at my Plan it says I’m on Channel SketchUp Pro on an Annual Plan…

Did you download and install SketchUp Pro 2019 desktop client, or are you running the browser-based SketchUp Shop?

Hi everyone, thanks for all the feedback.
I am running SketchUp Pro 2019 V 19.0.685 64 bit according to my About menu - my biggest concern is that there is a definite lag between a command and the result. It doesn’t happen all the time, but it does occur enough to make me wonder if I need to revert to an older version, where I never experienced the problem. I constantly use keyboard shortcuts for Component Edit/ Hide Rest of Model as well as X-Ray view, which are giving me the most noticeable lag. Possibly its a display driver issue (have also mailed GPU vendor for feedback).

Then again, there is also the issue of multiple faces created every time I draw a line across a face; I have to delete 5 or 6 faces before I can use Push / Pull - very frustrating…

I’d be interested to see a model that does this.

Arch_trim.skp (202.3 KB)
If I open this component and try to trim the line extension or push pull the triangular portion at the end… This was created from scratch in skp 2019 it is part of a bigger model but I have just pulled this out as an example.

I’d recommend you adjust your units to have more precision and turn off length snapping. Try this and I think your multi faces will go away.
Your model is just out alignment which makes SU create multiple faces because it is trying to bend them.
If you look closely at the extended edge you’ll find it is actually a tiny face and it steps from the corner.

Thanks,I have adjusted precision to 0.0 and turned off length snap and will see how it goes. How do you manage to see the extended edge so closely? As soon as I zoom in too tight I get viewport clipping… Can one adjust this value somewhere?

I don’t get that with the file you uploaded, but the camera is set to Parallel Projection. If you are using that camera setting in the main model that may well be causing the clipping. Set the camera to Perspective, it makes for an easier experience anyway.

1 Like