I'm super Displeased with Sketchup 2021

So I’ve been using Sketchup Pro for a few years now. I pay my monthly dues, and I don’t complain much! Has anyone else noticed how absolutely terrible Sketchup 2021 is performing? It really has me thinking about switching over to something from Autodesk because I don’t know what the developers did to this awesome application, but it’s not Sketchup anymore. Literally considering the learning curve for a new product. Exporting work out of Sketchup works occasionally. Migrating from 2020 to 2021 was a nightmare. Then when I tried to migrate back to 2020, the Google Sketchup Warehouse doesn’t work. I pay my monthly dues, what’s up with the state of this application? All I have to say is I’m not at all! Oh, and please don’t try to say it’s my system. I’ve run every other version just fine. Plus, I have an NVIDIA GeForce RTX 2080 Ti (it costs roughly $2500). I was very specific about this platform I built, and I wanted to make a very nice 3D workstation. I’m running an Intel i9-9900KF CPU @ 3.60GHz with 32.0 GB of RAM. Also, I have Windows 10 Pro installed. I really don’t know what to do at this point. I’m going to try uninstalling and reinstalling for the last try to get it performing as it should, if it doesn’t work, well, I’ll be heading over to Autodesk to see what I can find. I’ve been an avid supporter of Sketchup for a while now! Hey, if it doesn’t do what it’s always done, why would I stick around?



How is 2021 terribly performing compared to 2020 version ? Maybe we can help you if you give us examples

No, but my requirements may be different from yours…?

1 Like

This is not good to hear! What sort of issues are you seeing? I cannot, off the top of my head, think of any issues that would effect 3DWarehouse, based on version… If you can give us some specific examples of the problems, we may be able to help troubleshoot and get you up and running!

I’m puzzled. Google hasn’t had anything to do with SketchUp or the Warehouse for almost a decade.

What monthly dues are you paying? There aren’t any monthly dues for SketchUp.

1 Like

Could you explain exactly what it isn’t doing? My system is 1/4 of what you’re running, and I have no issues whatsoever. Is it just the export functions? Are you getting laggy renderings? Again, we don’t know what you’re needing it to do, so it’s hard to determine what may be happening.

The general consensus is that 2021 is stable and an improvement over previous years. It’s worth unpacking the issues you are having because they are not the common experience, and can most likely be fixed. There is a known bug in 2021 that causes 3D export of a selection to fail without report. Perhaps this is the export issue you wrote about?

1 Like

You are making a complaint as if you are speaking to Trimble. This is not Trimble but just a user forum. Lots of very knowledgeable people here that can often sort you out but not unless the problem is made specific.

As others have said, the users here have found SU2021 to be stable and reliable. You may not wish to believe it is something your end but that’s sure how it looks from here. But stick with it and maybe someone can figure out what’s going wrong for you.

1 Like

He/she joined today. This is his/her only post. I have seen several of these now. A person joins, posts an unspecified rant and disappears.

In this manner Lady Catherine talked on, till they were at the door of the carriage, when, turning hastily round, she added, “I take no leave of you, Miss Bennet. I send no compliments to your mother. You deserve no such attention. I am most seriously displeased.” (Austen, Pride and Prejudice)


I am hoping that the OP comes back at some point and actually lets us know what the issues are. I get the need to state dissatisfaction, but I hold high esteem for this forum and have a feeling that if people with issues work with the members, they will see their issues addressed, and may end up learning something new! I know that I do!


Ah yes, the old arrive, dump, leave routine!

I don’t remember that bit from P&P but it sounds great!

1 Like

I’m totally right there with you. My system is pretty performant, and It’s like a dice roll when I try to Export Collada, FBX, OBJ, and haven’t tried anything else but I really am so unhappy with this. It’s really irritating. I was thinking maybe they did that so people would update to 2021. Sketchup looks like it underwent a massive application rewrite. You guys changed the icon, nothing migrated correctly. To be honest, in my personal opinion, this application was rushed out the door. It had to of been. I own a Development company, so, I’m not talking out of my ass, either.

1 Like

Is that right? Maybe I’m a business owner who has more pressing matters to attend too. You know, rather than wait on customer support to help me fix a problem that worked fine in their last application.

1 Like

Lol, I love the fact the community members have nothing to contribute as far as fixing the problem, yet you will run your neck because I don’t wait on you guys. I was complaining about the software, and that’s my prerogative since I do pay monthly for the application. I’m obviously here to find a solution rather than move on to autodesk. This is where I was lead to fix the problem. So I’m here.

1 Like

Stable, improvement, I agree with all. Including the export bug. Of course that’s the issue! Is there any particular fix? Thanks

1 Like

I mean this is kind of a joke, right? You guys sit on this forum, only one of you have actually addressed the issue. Even he left me hanging on what the solution was, if there even was a solution to the issue. I mean you have to be pretty sad to want to come onto a forum and play message games with people. It sounds like some of you need to get a life. Hey, but rather than empathizing with a fellow Sketchup user, you sit here and gang stalk the forum and you can’t wait when someone looking for a solution shows up. It’s like I’m having a real issue, and I’m pissed at the fact I’m having the issue in what is suppose to be a stable version of the application. So, do you guys act super arrogant all the time? Or just when you can’t help the person seeking assistance? Yea, your one chance to feel above a person and it’s something you also have to wait for the team over at Trimble to fix. Lol

1 Like

On the question of exporting, there is currently a problem with exporting only the selection from 2021. If you export the whole model, or copy what you need into a new file then export, it works ok.

What is your current situation? Are you back in 2021 trying again, or in 2020 with a non working 3D Warehouse? If 3D Warehouse isn’t working, what symptoms does it show?

Everybody here is trying to help you. Your original post alluded to unspecific problems with SketchUp “performing terribly”. That is not enough information for anyone to help you improve your situation. You asked if everyone else is experiencing this terrible performance, the answer is No. The differences between SketchUp 20 and 21 are few and subtle, it’s not at all clear what specific changes you are seeing that have made you so upset. I certainly would not describe it as a “new product” in fact unless you know exactly what small things to look for the interface is identical. I’m confused at what you are seeing that is so different.

People are asking questions to try to better understand what the specific problem is so they can help you. Perhaps you failed to install 21 correctly by right clicking on the installer and choosing run as administrator, perhaps you have a hung up non-compatable extension, perhaps Windows 10 performed a background graphics card update recently that broke the pipeline and needs to be updated with the manufacturer, or perhaps… all these possible and are all fixable but we need information to diagnose the problem.

This one sentence is all I have to go on about your export problem. You don’t tell me what type of export you’re attempting or the circumstances under which it fails or how it fails. I’m taking a wild guess when I suggested the 3D export selection bug. If my guess is correct then the bug should only manifest when you attempt a 3D export and have the export only current selection box checked. This is true for all file types. But it is not intermittent as you suggest, it never works, exporting selection fails every time and exporting the entire model succeeds every time so the working “occasionally” part makes me wonder if there is some other problem or misunderstanding you are experiencing. I didn’t offer a solution because I was not sure of the problem, I was asking.

The current workaround for the export selection only bug is to export the whole model, or copy paste the current selection into a fresh file and export from there as @colin suggests.

Again I have no information from you, I have no idea what type of file you are trying to export, If you are trying to export .STL then another option is to download the Export STL Extension written by the SketchUp team from the extension warehouse which will add an Export STL option to your File menu, that Extension can export .STL selections only just fine.

If you could describe any of the specific changes you are seeing, or the performance problems you are having perhaps we can help you solve the problem.


I would advise you check the insults at the door if you’re wanting help, friend. You posted a message that seemed pretty upset in tone about a serious issue you’re having. People leaped on here to find more information (that you have yet to provide us) so they could help you. Then you went silent. Given how big of a problem this appeared to be, it seemed pretty odd to just disappear and not hear from you. I’m pretty sure we’re all working while we’re on here, and just chime in when we can. I’m brand new here, and everyone has been nice to me so far (apart from all the teasing and name calling), so I don’t think the problem is the group. It might be that things just got off on the wrong foot due to perceived tone, as they often do in email and text.

So, in detail, what types of files are you trying to export (size, poly count, original or downloaded)? What are the errors you’re seeing on the exported side?
What other issues (if any) are you having?