Frustrated with Sketchup Pro crashing and not 3d exporting

While Sketchup Pro has been great for relatively simple objects, I am now creating very complex objects and Sketchup Pro 2021 is constantly crashing and refusing to 3D export. For a while I could export in OBJ but not STL. Now I can’t do either. It feels like I have outgrown the product. This may be a Mac only problem, by the way. I have uploaded the current version of the file. I am only exporting one of the two objects at a time, either by hiding one or just exporting the selected object.

Can someone on a Mac try this? I am also crashing the program frequently using solid tools with these complicated objects. These are to scale but I am designing at 8x. I can’t export at either resolution.

Top and clamp.skp (2.5 MB)

I exported them as .stl files on my Windows machine with no problem.

Are you OK with non-standard threads?

Interesting. So this may be a Mac only problem.

The threads are not standard. The two parts just need to mesh.

Thanks.

I don’t think this is a Mac problem. On my Mac I was able to open and work with your file without crashing and export both of your pieces as .stl and load them into Cura for printing just fine. I generally do not experience much crashing of SketchUp or Layout on Mac.

This might be a problem with your specific installation or a conflicting extension, is SketchUp loaded into the applications folder, not running off the desktop?

You might be running into the tiny geometry issue when using solid tools on such small geometry.
SktechUp has a lower tolerance of about .001", edges smaller than that such as are created in tiny radius curves cause errors and prevent faces from forming, it could also be causing crashing if you are running out of ram in calculating the number of edges created in a complex solid operation, although the edge count for this model is pretty modest at around 50k.

General best practice for 3D printing is to model at 100 or 1000x scale. I model in M and treat them as MM, many others do the same. With this practice I never have issues making any type of complex geometry. .STL is a unit-less format, so the actual units used to model is not recorded in the file, what matters is the unit set in the import process into your slicer. I leave my SketchUP model in meters, export as-is without any scaling, and have set Cura (my slicer) to read all .stl files as MM so there is no scaling on either end, things just appear in the slicer at the correct size, this is a common workflow.

The 2021 release of SketchUp introduced an unfortunate Bug which causes the Export Selection function to fail, in any file format. There is no error window, it appears to export, but no file is created. You cannot 3D export a selection only until this is fixed with a new release, no telling when that will be but the SketchUp team is painfully aware of the problem. For now you can copy paste to a new file and export, or download the STL export extension from the SketchUp team which will restore the export selection function through the file menu.

2 Likes

Lots of helpful stuff here. The export failure is exactly what you are describing. It partially goes through the motions but doesn’t generate the file. I will try the export extension. I didn’t know about that. Thanks!

Interesting comment about scaling up. I have been using 4x or 8x scaling a lot since the follow tool frequently fails with small parts at scale. Going to 100x to work makes sense. I reduce to scale before exporting to CURA typically.

1 Like

I’m using an iMac (Mojave) with SU2021. I tried your file and it crashed.

I also experience regular crashes with solid tools, so much I stopped using. My crashes generally occur when using extensions or on closing SU. I also regularly send reports to Apple and SU. I have not received any helpful suggestions.

At one point I completely wiped the machine, reloaded only SU2021, with few extensions. The frequency of crashes went down (2-4 in 6 hours), but did not stop. I did not have this problem with SU2019/2020.

As of today, I have reverted to SU2017 which is producing a stable work environment (no crashes so far ~5 hours, fingers crossed). I am adding extensions one at a time. At my level of expertise trying to troubleshoot whether the problem is hardware or software is bewildering and greatly frustrating.

I’m giving up a lot by using SU2017 but a stable work environment is critical. I also prefer the Mac environment, but will probably move to Windows in the future. Looking at the prevalence of crashes being reported on this forum, leads me to believe that SU on Windows is the more stable environment.

Hope your Mac experience improves …

Untitled
I am on a Mac, Big Sur 11.2.3 SketchUp 2021.
took less than 3 seconds to export:

1 Like

Interesting that on some Macs it works and others it does not. I crash with solid tools all the time as well. All this started when I upgraded to 2021. I think I will downgrade to 2020 and see if that works better. Can I open 2021 saved files in 2020?

1 Like

Found this on the SU website. Looks like you have to save the file to an earlier version first.

Every major version of SketchUp (eg, 8, 2015, 2016, 2017, 2018) has a unique version of the *.skp file format. As such, the model needs to be saved in the correct version of SketchUp that will open the file. But don’t worry, you can “down save” a model so you can open the file in an older version

This is what my 2017SU version save displays. Would guess your 2021 would have a 2020 option.

Are you submitting Bugsplat and/or Apple reports? I asked @colin to look at my Bugsplats, did not get a definitive response, but he may be able to assist you. Seems to me with all the diagnostic data contained in these reports, the errors should be identifiable.

You might find these posts interesting, as they seem to question code quality in SU2021. If you do down grade to SU2020, I would be very interested in any changes (good or bad) with your issues. Thanks.

There is currently an issue with exporting the selection. Until we send out an update that has that fixed, you would need to export the whole model, or copy what you need into an empty document, and export it from there.