SketchUp 2019 is lagging as soon as start

Hi all,

My customer has problem with running SketchUp 2019 Pro.
As I mentioned it, his SketchUp is lagging from start.
His graphic card is up to date and CPU is also nice.
Intel Core i7-8750H CPU
Geforce RTX 2070
32GB RAM

He doesn’t have any ruby.

What should I do him to use SU 2019 pro properly for him?

Any comment would be helpful.
Thank you in advance.

Perhaps, search the forum for " run as administrator ".

Thank you for your reply. However, it was not that issue.
He just accustomed to it then use SU like that now…

1 Like

Be sure the customer is running SketchUp using their Nvidia GPU.
Window > Preferences > OpenGL > Graphic Card Details

Thank you for your reply.
He is using NVIDIA graphics card and already managed it, and I checked it also.
Nothing happened…

So, the problem is still there?
What exactly do you mean with lagging? When it is loaded, can the model be handled?
Does it lag with all files?
Try closing the Material and Component panels in the tray(s), Do you see improvements?

Lagging as soon as start SU 2019, from mouse performance to all.
Even in empty drawing, mouse performance is lagging.

Does the computer has more then one account? Sometimes, an account can get corrupted. Without having to completely reinstall anything, you could try to ceate a new account and see if it happens there, as well.