Sketchup 2019 - Crashes 1 minute after starting

Just purchased a new HP laptop and I seem to be running into an issue with Sketchup 2019. The issue is the program refuses to run more than 1 minute. It will crash regardless of use, I can open, minimize window, then 1 minute later the screen will typically flash black, and then Sketchup will close. No bug splat screen, not once. After searching the forums here is what I have tried:

  • Reinstall/repair as administrator
  • Updated Nvidia driver
  • Made sure Nvidia is dedicating its High-Performance Processor to Sketchup
  • Turned off Fast Feedback in Sketchup
  • Computer has been reset multiple times

Funny enough, Sketchup 2018 runs without issue. I would be happy to use this version of the program, but unluckily I can’t seem to get my subscription to cover this previous versions. I do not have a license to type in. I feel like I am running out of options, and I don’t really want to use my 7 year old macbook pro to run 2019 (works like a charm on that machine)

Thank you,

Model: HP Spectra x360 15
Processor: Intel Core i7-8565U CPU @ 1.8GHz
RAM: 16 G
64-Bit OS

When you did the installation / repair did you RIGHT CLICK on the .exe file and choose run as administrator?

Yes, I tried reinstalling as administrator. I also tried repairing as administrator. Have been trying to also run the program as administrator. All by right clicking the program icon.

Have you tried a different download?

Yes, second download has produced the same results. Is there a current conflict issue people are aware of with the 2019 version of Sketchup?

None that I am aware of. Will SU run off the on-board graphics? If yes something is not right with the nvidia set up. I would be considering contacting HP about a possible graphics issue.

That might be a leaking memory? If you open the taskbar and choose the memory tab, do you see an increasing usage?

Update your nVidia GeForce drivers directly from the nVidia site.
https://www.geforce.com/drivers/results/150583

No increase in CPU at all while program was running. Though, there was a 100% spike of GPU usage at the moment of crash. Going to re-re-update my nVidia Driver now.

Drivers are all up to date. The issue still persists. I have noticed I run into a similar issue with Photoshop, only PS says graphic acceleration needs to be turned off instead of crashing. Not sure if this is just a running issue with a graphics card on these machines.

I reached out to Customer Service at GeForce. They suggested the following:
Open the Nvidia Control Panel. Go to Manage 3D settings–>>Global settings–>> Power management mode - Prefer Maximum Performance.

Since this one tweak, I have not had any issues with GPU spikes.

3 Likes

this should be the only option…:wink:

3 Likes

I have exactly the same problem. I bought an Hp laptop two months ago and I cant use sketch up 2019. I have downloaded the 2018 version to use it because I just read what you have written and its working fine till now. I don’t know what to do, and the hp team support either. Please if you know the solution tell me. Sorry for my English, im from Argentina. But the laptop is form the US