Sketchup Pro 2019 freezes Windows computer

I’m 4 days into using SketchUp Pro 2019. It has frozen my computer at least 12 times. Control Alt Delete doesn’t even work. I have to hard stop/start my computer by holding down the power button. I have an Inspiron 17-7778, processor Intel Core i7-6500U CPU@2.5 GHz, 2.6 GHz, 16GB DDR4 RAM, 512GB SSD. NVDIA GeForce940MX video card. This computer is powerful enough to run AutoCad.

I read some forum posts about Managing the NVIDIA Control Panel. I changed the setting to High-performance NVIDIA processor. It WAS set to NVIDIA GPU. This seemed to help. Instead of freezing frequently (hourly) it now freezes less frequently (4 hours). Possible this wasn’t connected at all to the issue but thought I should mention it.

Please help! I am loving SketchUp and want to solve this issue!!!

Thanks in advance.

When you installed SketchUp did you right click on the downloaded installer file and select Run as administrator from the Context menu?

No I did not. I just did it now. So I should click run as Administrator everytime I open sketchup or just OPEN from now on?

You only start the installer with “Run as administrator”. You run the application normally, either from the shortcut or by opening a SKP file.


Update Nvidia driver.

Check inside SketchUp to be sure it is using the Nvidia GPU.
Window > Preferences > OpenGL > Graphics Card Details

Turn off any rendering extensions when not actually rendering.

If still locking up, …

  • get a memory check utility and check system RAM.
  • get a hard drive check utility from your HD manufacturer and check the drive.

It sounds like I need to reinstall. And at some point I will see “run as administrator” during the new install?? Instead of what I just did which was click “run as administrator” from the already installed sketchup pro icon on my desktop?

Thank you for your help!

No. At this point make sure SketchUp and LayOut are both closed. Go to the installer file you downloaded from the website. Right click on it and choose Run as administrator. In a moment you should get a window asking you what you want to do. Choose Repair. As Dan said, this is done when installing the program, not when you are opening the program to use it.

Screenshot%20-%208_19_2019%20%2C%2010_24_53%20AM

Screenshot%20-%208_19_2019%20%2C%2010_25_45%20AM

1 Like

Done. Thanks so much. Fingers crossed for no more freezing!

2 Likes

Besides the graphics, the save location of the model and/or the model size itself can be of great influence.
Best practice is to have you model on your local (hard) drive, not on a USB-disc, server location, cloud based Google- or iCloud drive or to have it ‘synced’ with dropbox.
Especially in combination with the autosave, this will lead to broken, unreadable files eventually.

Window->Preferences->General to control autosave, one tab back (->Files ) for the File settings of the models, components, materials etc.

2 Likes